Copter low thrust help

Hi, I have an orange cube on a 4 rotor with dshot esc with a 3s battery. According to the motor’s specs 930kv and esc specs of 35A everything should work. I already calibrated everything but the copter doesn’t want to liftoff, at most I only get jumps or hops. Any idea?

Not enough information.
Questions:
What 930kv motors
Prop size and pitch
Take-off-weight (incl battery)

motors: GARTT 2CW 2CCW ML2212S 920KV
props: 1045
weight: 1300~900g

OK, ~1kg would be about right for that kit of hardware on 3S but it should lift off at 1.3kg. You wouldn’t want to fly at that weight though. Attach a link to a .bin flight log of a take off attempt.

https://drive.google.com/drive/folders/1-ij6MuUmY3Px-I-GRAWdjvmYG_9B7lGl?usp=sharing

There are tweo files only one armed, sorry I don’t know which one, haven’t learned to read this yet. I suppose the heavier file is the one that armed.

1045 props should work for that but something isn’t happy. Motor 3 is hitting max so even on 3S that quad should be moving. There’s also some high vibrations but if the quad is bouncing on the ground that could be misleading information. There’s a bias to the right side of the quad, like it’s leaning to the right. Was the quad level when you started?

Some things to check:

  • Are the props installed in the right places?
  • Is all the hardware tight?
  • How is the flight controller mounted? Is it secured or is it moving? Has it been moved on the airframe since you did the initial calibrations?
  • Are all the arms secured?

You weren’t tethering the drone?

Yes the props are on the correct side inverted from one another.
Well, the drone is ~30g heavier on the right side and the floor is like 5 degrees to the right also.
The controller is at the front center, and everything is very tight.
No thether, it only hopped/stumble around a 100cm area at most.

The controller was not attached to the drone at the moment of calibrating.

Did you use the motor test in Mission Planner to verify the motor spin direction?

Yes, I also used it to see the dead zone of the esc.

A couple observations. You have Dshot configured but on a Cube Orange Dshot must be assigned to the Aux outputs. You have them on the main outputs. Also, you have MOT_SPIN_ARM higher than MOT_SPIN_MIN. This is incorrect.

And where did you come up with these?
PSC_ACCZ_I,1.08
PSC_ACCZ_P,0.54

1 Like

Wow didn’t know that, and kinda smells that it could be it! let me reconfigure and I’ll let you know tomorrow. Here in Europe is very late, thanks for your help so far.

No f**ing clue about those, honestly I don’t even remember them. Should I set them to 0?

Ha, no. If you don’t know you should set everything back to default (start over) and then re-calibrate, re-run the Initial Parameter Setup and assign the motors to the Aux outputs. That would be baseline. Then you would setup to configure the dynamic notch filter because that’s the next step assuming it lifts off the ground. What ESC’s are they because there are other parameters to set or potentially a different firmware to flash.

This might help:

https://ardupilot.org/copter/docs/common-dshot-escs.html#configure-the-servo-functions

Ok so I did not go to bed, rearranged the cables to aux 1234 to their corresponding escs, and set default everything. Re calibrated things, chose servos 9 10 11 12 as motors, disabled the safetyswitch to arm to 0 AND the esc beeps constantly when un-armed after arming they spin and seem to have power, but as soon as I disarm it beeps all the time like 1 time per second.

Also how do I tun off mission planner audio warnings?