Copter is losing orientation on aggressive turns

Hi all. Still fighting with AP tuning.

Problem is when I’m frlying in ACRO copter is losing oruentation on fast(agressive) turn (this is NOT PROP wash). I’ve increased ATC_THR_MIX_MAN = 3.5 - does not help! :frowning:

I’m not sure about filters configuration. I do have 3.5" 4s quad in about 310g weight with battery.

It’s flying OK in Betaflight. I’ve lost in about 3 weeks trying to find the problem. And now I’m thinking to go back to BF :frowning:

Can somebody please advise?

Logs: 5 01.01.1970 1-00-01.bin - Google Drive

And thanks in advance!

I’ve done lots of series tuning for acro in particular - presumably you have looked at them?

1 Like

Hi man!
I was looking your series about chimera (thanks for that!) - I have it too :slight_smile:
I was not looking on this specific series of your videos. But was trying to do in same way as you did with chimera.

Problem for me I did not get how to define right filtering. So I do have (in my opinion) good chart - but I’m not sure.

The noise looks ok. I think you could go narrower on the notch and the reduced phase lag will let you get a tighter tune. Given that you are using ESC telemetry you should be able to use FREQ 40/BW 10 and it all work as intended.

Your problem simply sounds like tuning. Fast aggressive turns generate a lot of noise which can affect the attitude controller. The control doesn’t look bad. Try the narrower notch and retune. What AGGR setting did you use when you did autotune?

Also you have Yaw D set but no FLTD for yaw which means you will get noise coming through yaw - set yaw FLTD to GYRO_FILTER/4 and retune

Hi Andy

I’m using AGGR = 0.1. Then tried with manual tune to increase P - was no lucky :slight_smile:
Thanks for that. I’l try to update filter. And let you know

What do you think about GYRO_FILTER - is that OK for that quad?

Try AGGR 0.075 when you have made the other changes - you may have also created instabilities through gains that are too high

Thanks - I will try. Instability was before manual changes :frowning:

Nothing changed :frowning:
is still trying to tip the drone in the opposite direction when making a sharp turn.

The situation is slightly improved by ATC_THR_MIX_MAN = 4, but this is the maximum value that the AP allows to use (resets to 4 on reboot)

Logs from the next flight right after autotune

You have a fairly pronounced spike at 182Hz:

Most likely this is frame resonance since you are blasting about and your RPM is well away from this. This will prevent you increasing your filters any further so I would use the second harmonic notch to take this out. When you have done that you should be able to raise your filters so that you can get a tighter tune.


Hi Andy, thanks for that.
I’ve tried to change props on smaller ones from 3.5 to 3. Looks like you are right.
I’ve got something like this:

I hope that’ will help :slight_smile:

Multisource on the fixed HNTC2 is just strange.
And setting only the 6th and 7th harmonics at 6 * 39 = 234Hz and 7 * 39 = 273Hz respectively is also strange, but it does seam to work…

1 Like

What motors do you have?
I’m working on the harmonic notch filter for you.

You will want to set:
and maybe dial back some logging, and add some normal things in

1 Like

@xfacta : 1404 IFlight XING 3000KV 4S.

Looks like main problem was gone after static filter. I increased ATT to 40DB

The only thing I’m thinking was it over filtering?

That motor is 12 Poles, you will need to set:
and I would try this filter configuration with a flight to see what the log is like then:


It is nearly the same as you had in the last log but just standardised/minimised.
The number of poles explains why even in steady flight the notch was not matching the noise peak:

but it should be good now.


Thank. I was double checked nomber of pols - in some kind of reason I was missed N and P :person_facepalming:
Next few days I can’t test changes - because hawy rains here. I’ll let you know when I’ll get results.

Thanks all

So. Looks like problems was in number of poles. After setting correct value - it’s flying well!
I removed static filtering. Changed notch to 80/40. And no spikes after filter (even with 40/10)

@xfacta , @andyp1per thanks for your help!

1 Like

Use 80/20 at most if using per-motor notches

1 Like