Copter goes wild in stabilize or Auto mode

Hi, this is my first time here. I am using APM mini 3.1. Copter goes wild always if I switch flying mode from default manual to either stabilize or Auto mode. First time when switched t Auto, it flew like rocket and disappeared, found later in bad shape from a parking lot 300 meters away. Second and third time, properly planned a mission by defining way points and set alt to 2 meters only. For safety tied with a string, switched to auto and same thing, it suddenly increased motor speed to very high and tried to fly in different direction and very high but tangled with rope and crashed. Same thing with third time. My 3 motors and 2 esc are completely damaged. Other damages are extra. What am I doing wrong here. Why and where copter are going when switched to auto/Alt hold or stabilize mode. I am now out of spare parts to continue repairing after each crash. Would be very thankful to helpers.

Need logs from flight but it’s probably bad vibrations.


I tried to download all logs but got error message like “system.error” in loading log file(s)

Unless they are small you can’t upload them. You need to put them on a cloud drive and share the link here.


The problem is not size. I am getting this when tried to download

Getting list of log files…
No logs to download
Getting list of log files…
Error:System.Exception: Timeout on read - GetLogEntry
at MissionPlanner.MAVLinkInterface.GetLogEntry(UInt16 startno, UInt16 endno) in c:\Users\michael\Source\Repos\MissionPlanner\Mavlink\MAVLinkInterface.cs:line 4053
at MissionPlanner.MAVLinkInterface.GetLogList() in c:\Users\michael\Source\Repos\MissionPlanner\Mavlink\MAVLinkInterface.cs:line 4004
at MissionPlanner.Log.LogDownloadMavLink.b__0() in c:\Users\michael\Source\Repos\MissionPlanner\Log\LogDownloadMavLink.cs:line 92

Does it means my APM or GPS is broken?

Sounds like the internal memory card is corrupted.