Copter flipped while flying in Loiter mode

Hi all :slight_smile:

I just made my first quadcopter using the APM. Everything was just fine and after doing the first basic calibration like in the manual i was wondering how stable my copter flew when i did my first flight. I thought it would be more unstable and that i have to do more tuning (of course some fine tuning has to be done because it reacts a little twitchy… but i was impressed how stable it was without tuning) whatever :slight_smile:

Everything was very good and i switched to loiter mode for more assistance (i am a newbie more or less)… the copter was very stable and i would say it was holding its position perfect. I flew a little forward and stopped and then suddenly the copter flipped and fell to the ground… i have a 3dr telemetry attached and i looked into the logs… i was checking the “Diagnosing Problems using Logs” section in the manual and i think the problem was a brown out because all other graphs look okay i think… but maybe some of you can have a look at my tlog and tell me if it really was a brown out and what i can do to prevent this… i use the 3dr power module to power the apm… maybe it was a problem that i didnt cut the power cables to my esc’s from the apm? or should i open the jp1 jumper? like i said… im quite new to this stuff… hopefully somebody can help me :slight_smile:


Greets from germany :slight_smile:

do you have dataflash log as well?

yes i have. i had to pack it because it was to big.

and some additional info: i just figured out that my jp1 is open and the board which i have ( the case is labeled with “Arducopter”) has no possibility to set the jumper (pins are missing). But at the time i flew with the copter all esc becs were connected to the output of the apm (i just didnt know that i have only to connect the signal cable of the escs)… is it possible that this is responsible for the crash?

OK, here my quick look

Des pitch and pitch diverge, so it is trying to to fight the pitch change. If it was a motor fail or something else in the drive train I’d expect pitch and roll to occur for an X quad (I assume its x rather than +?) rather than just pitch

Your accel Z has a massive glitch on it, so I am struggling to zoom in an see what you vibrations look like, very odd.

The logs do seem to stop while at altitude which matches the auto analysis you mention, so maybe you do have a wiring issue. If a motor failed or something the log should continue till it hits the floor and hopefully while on the floor too asthe brain will be alive. Maybe the power went and two of the esc lost power first briefly before the brain lost power ending the log where it is and it falling.

JP1 open is fine, if it was there it would connect the esc 5V to the power module 5V, not what you want. Better to just power using the power module and leaving JP1 open.

Have you powered it up since?

first thanks for ypur reply and your help :slight_smile:

you are correct it is a x-quad not +.

i have no idea where this glitch is coming from at the IMU acc values… I think accept for that glitch the vibration values are okay? i mounted the apm on a anti-vibration platform like suggested in the manual.

i powered it up since the crash… all looks fine… apm is working, arming is possible and motors are spinning… i cant imagine where a wiring issue could be… Battery goes in the power module and then to power distribution board from ebay and then to escs (turnigy plush 25A). As the seller told me: 4x 25A is absoluteley no problem for the board… From the power module of course there goes the 6-pole cable directly into the apm… so i think i wired everything right?

i read that in loiter mode, the copter should smoothly stop if you relase the pitch… Unfortunately that was not the case… it braked really hard and after that it flipped and fell down…

do you need some additional info on the hardware i use? or some other info?

Sounds like it is wired up in the correct fashion. Not sure what to suggest other than carefully examine the wiring wiggling connectors. Checking for shorts, although there are no obvious glitches on vcc or volt

I couldnt get mission planner to zoom in enough to see accel z properly.

Does sound odd with the loiter though, it will try and stop but shouldn;t flip…I think its coincidental.

The log just ends so looks like it went dead mid air rather than loiter getting confused. If it was bad tuning tyhe log would continue at least until it got killed by any damage from landing

ok i just figured something out i think :smiley:

i wiggled at some connectors like you said and then found out, that there is something wrong with my telemetry… if i wiggle the connector at the sender it looses power sometimes. The problem: the apm now made 2 restarts when i started wiggling on that thing… tha last time i wiggled , the apm turned off and never came back…

maybe the telemetry sender is broken? the connector and cable is very bad quality… but what can cause the apm to restart or shut down? a short?

A short would do that as it would drop the Vcc below safe level. Is it at the APM end or the telem module end? It’s not clear from what you said, apologies. Is it a gentle wiggle? Like could possible occur from vibrations?

Maybe try a new cable? I hate to suggest buying parts that may not be the issue, but it is probably a cheap thing to try.

Maybe try some low level hovers without the telem fitted? Also not nice to suggest but intermittent faults if it is intermittent are a pain :slight_smile:…I am an engineer by trade and I detest intermittent faults :slight_smile:

Sorry , sometimes my english is probably not the best :wink:

it was at the telem module end… and it was a very gentle wiggle… i powered up the copter and then saw that the telem leds were not flickering… then i only touched the cable a little and it turned back on… then i started to wiggle a little bit and saw that the telem turned on, off, on, off … and suddenly the apm lost power and made a restart …

i now changed the connector and everything is fine now… no more power losses and no more apm restarts :wink:

maybe that was the reason for my crash… Like i said the copter braked very hard and then maybe the telemetry killed the apm and then it crashed… sounds like a possible scenario for me. i also checked the other cables and connectors as you said but cant find other issues :frowning:

i think i have to fly the copter again, make some tuning and maybe everything is fine now :slight_smile: hopefully it is not a intermittent fault :wink:

i post my results here

Thank you very much for your help :slight_smile:

Your english is very good…native english speakers aren’t always clear.

Good work, it does sound like you found the issue.

Good luck

Sounds like you guys got it.

The telemetry module probably has some large caps in it that are sucking down the APM Vcc when it reconnects.

just wanted to tell that i made another testflight today and everything worked fine :slight_smile: i think the problem is solved. how can i mark this thread as “solved” ? do i have to accept a answer? thanks again for the help :slight_smile:

Good work.

Yeah accepting an answer does it.

Happy flying