Copter-4.5.0-beta1 available for beta testing!

I have a crash today with a quadcopter on 4.5 during autontune.
Here are the log if you are interested.

550mm quadcopter, 15’’ prop, liion 6S 80000Mah, pixhawk4, around 2.5Kg…

I was doing autotune, the drone did roll autotune for about 10min everyting was going well, then goes to pitch autotune was going well for 5min then sudently he goes in spiral down to the ground.

Ask if you need any more details.

Best regards,

You lost motor 2. Likely a desync if it still works afterwards. Check the ESC and motor carefully for wiring or shorting issues and if all looks good then you need to suspect your ESCs

1 Like

Thank you for your prompt feedback.

The 4 motors are still working, I’m dismantling them and I’m going to check the wiring as you advise.

What I find strange is the coincidence just after the firmware change when this drone has already flown a lot.

Best regards,


Thanks for the feedback and to @andyp1per for the analysis.

Unfortunately ESC de-sync is a common problem with AutoTune so I’ve added an issue for the wiki to add a warning.

Hi what is the lua script you talk about and what he does?

When configuring the ESCs with the provided 07_esc.param file there are parameters in there that mitigate the de-sync probability. Have you read that? Have you used it?


which parameters, specifically?

1 Like

*_SMAX to limit the slew rate.

1 Like

Have you used the method already? Any early comments on it?


I have the same problem using autotune (crash…). Now I tune my cube-orange step-by-step using the guide from amilcarlucas. There are tons of useful information there!!!


Will VTOL-quicktune work on a baby Y6 asking for a friend. lol


Look massive overpowered. Please do report on the speeds you achieve with it.


Looking good! I think it should work.

1 Like

@rmackay9 - thanks to you and all the developers for making ArduCopter a great resource!

Could you describe the changes related to ROS2/DDS support, from v4.4.4? Is DDS not supported on v4.4.4?


No it is not. You need ArduCopter 4.5.0-beta1 or newer.

Is this directed to me?

yes, To you @Quadzilla and is meant in a positive way.

1 Like

Do you mean that your problems are now solved?


I think that Ryan (maintainer of AP’s ROS libraries) will provide more details on the ROS2/DDS changes in the near future. Until then our ROS wiki pages have some setup information.


No, I didn’t say I’ve solved all the issues. But by following this guide step by step, I’m gaining a deeper understanding of how Ardupilot works. Today, I went flying and got a log file to analyze vibrations and fine-tune the filters.