Copter-4.4.0-beta3 available for beta testing

Copter-4.4.0-beta3 has been released for beta testing and can be installing using Mission Planner or QGC’s beta firmwares link. Alternatively the .apj file can be manually downloaded from

The changes vs -beta2 are in the ReleaseNotes and also copied below

  1. Autopilots specific changes
    • Holybro KakuteH7-Wing support
    • JFB100 external watchdog GPIO support added
    • Pixhawk1-bdshot support
    • Pixhawk6X-bdshot support
    • SpeedyBeeF4 loses bdshot support
  2. Device drivers
    • added LP5562 I2C LED driver
    • added IS31FL3195 LED driver
  3. TradHeli gets minor fix to RSC servo output range
  4. Camera and Gimbal related changes
    • DO_SET_ROI_NONE command support added
  5. Applet changes
    • added QUIK_MAX_REDUCE parameter to VTOL quicktune lua applet
  6. Bug fixes
    • ADSB sensor loss of transceiver message less spammy
    • AutoTune Yaw rate max fixed
    • EKF vertical velocity reset fixed on loss of GPS
    • GPS pre-arm failure message clarified
    • SERVOx_PROTOCOL “SToRM32 Gimbal Serial” value renamed to “Gimbal” because also used by Siyi
    • SERIALx_OPTION “Swap” renamed to “SwapTXRX” for clarity
    • SBF GPS ellipsoid height fixed
    • Scripting restart memory corruption bug fixed
    • Ublox M10S GPS auto configuration fixed
    • ZigZag mode user takeoff fixed (users could not takeoff in ZigZag mode previously)

We think we are getting fairly close to the official 4.4.0 release but there will also certainly be a -beta4. In any case we would greatly appreciate any testing and feedback the community can provide.



I was able to get out and fly 4 batteries on the same two quadcopters as I did on beta2. Just the same general flying I like to test guided and rtl. I wanted to test an auto mission but my laptop decided it was to hot for its liking and shut down before I got it uploaded. Both these quads are 6" running mrobotics pixracers.

@andyp1per I bumped up my ATC_RAT_YAW_D to 0.001 and was able to complete a yaw-d term autotune on this quad here. Although I was an idiot and forgot to brush up on autotune sequence so I didn’t get them saved which is fine I guess I can pull them from the logs. It does compete but I takes an excessively long time compared to other autotune axis. It stayed at AutoTune: Yaw(D) Rate D Up 0% for quite sometime. I had four batteries so I decided to fly them down. This is just some general flying of the same quad here. I do have my angle_max up to I think around 60 degrees and there was a cpl times I lost gps. Is there anything in the log I can look at to see if its my setup that did this or the area I am flying in.

The second quad I flew was pretty much the same minus a different 6" frame. I thought I heard the sound for the second quads autotune but I must have been hearing things and when I looked my laptop had gotten hot so I couldn’t see the log file on my laptop. Then I just decided to burn the last battery and flew the rest of it out here. This one also took a very long time to start gaining values for the yaw d term autotune.

1 Like

Thanks for the testing! In the first log your D value never got beyond 0.001, so I will need to chat with Leonard about what is going on.

Leonard had a look at your log. The basic problem is that your build is too noisy - it’s amazing autotune works at all. So I think you need to work on your filter setup to get the noise down.

Just change this:
and good to go!

Is that because you are seeing four peaks. So I had half of my notch filter setup correctly then? I am just trying to get better at understanding logs and how to set the filtering up. Do you mind sharing how you came to that setting? I ran that log through the new fft tool but honestly I do not know what I am looking for quiet yet.

INS_HNTCH_HMNCS was 0 which is essentially “don’t filter any peaks”
Your other settings were already suitable - I’ve checked in the Filter Review Tool.