Copter-4.2.0-rc3 available for beta testing

Copter-4.2.0-rc3 has been released for beta testing and can be downloaded/installed using MP or QGC’s beta firmwares links.

The changes vs 4.2.0-rc2 are in the ReleaseNotes and also copied below.

  1. Bug fixes
    a) Blended Z axis accel calculation fix when not using first IMU
    b) Custom compass orientation for DroneCAN compasses

This is quite a small release and it could be the final release before 4.2.0 is released as the stable version.

Any and all feedback is greatly appreciated!


Lua scripting engine now works on my Pixhawk 1 (in 4.1.5. it did not work).

1 Like

when Copter-4.2.0 will be released? It’s gonna be great. I can hardly wait.

1 Like

Hi @ztzintelligence,

4.2.0 is getting close but I’m afraid two little issues have come up meaning there will be one more release candidate. I hope to release that final release candidate (“rc4”) today or tomorrow and then hopefully release 4.2 as the official version one week later (maybe Fri May 20th).

Hi, relatively new to Arducopter, so hope that this is the right place to report issues. Am using Copter-4.2.0-rc3 on a Diatone Roma L5, flashing to a Matek H743 flight controller and using an iFlight 4-in-1 ESC (flashed with BlueJay). As part of the set up, I did a motor test, and all the motors span up in sequence, but when I go to arm to fly, I observe the following behaviour:

Initially, nothing happens. I disarm and arm, use full right yaw when arming, and at some point, 3 of the 4 motors start to spin (on different occasions, it is different motors that don’t spin). Keep on arming and disarming, and eventually, all 4 motors start to spin and then everything appears ok.

Is this something in rc3, or is there something I need to change, check or set?

Thanks, Bill

Can you post your parameters? Do you get the motor arming tones immediately or do they come when the motors eventually turn?

I get the normal tones from the ESC, a long tone, pause, a short tone, pause, and then the final 3 beeps.
Roma L5 20220512 1536.param (20.4 KB)

You have SERVO_DSHOT_RATE=2 and SCHED_LOOP_RATE=400 which means the dshot rate is 800Hz which is a bit slow. Try SERVO_DSHOT_RATE=3

Hey Randy
Hope you and yours are well. Is there some document that explains what 4.2.0 will be all about. I am thinking about the reason to upgrade. What are the advantages to it. Not sure you can answer that but thought I would ask.


Same behaviour, but it took me fewer attempts to get all motors running…

Try a higher number - 5 say

Just tried it on 4, same behaviour, but motors were twitching and spinning for a couple of cycles even when disarmed. Will try 5.

Only 2 motors span up after nothing on the first couple of arming attempts, then 3, and then finally all 4. Still twitching…

Tried 1, same thing…

Do you know how to use mavproxy? Can you send me the contents of @SYS/timers.txt ?

No, not come across mavproxy. Am downloading the installer now and will have a look at it.

When you are connected:

ftp get @SYS/timers.txt -

I imagine this is something to do with dshot timing on your board with BlueJay

How do I connect on the cmd line? I have USB COM8 as the quad.