Copter-4.1.0-beta released for beta testing!

I get it here: ArduPilot firmware : /Copter/beta/F4BY

There is no bdshot version of the F4BY firmware

This is embarrassing. I tested hex, cuav and pixraptor. Their IO can’t support two-way communication. Can I try the antique pixhawk2.4.6

So another question, how can I use the stable version of pix to realize the function through independent return? In my other question, it seems that it doesn’t work normally

Wow , Excellent long work. Thank you to all Developer team. Bravo… I hope I can test it …

1 Like

Bdshot is not in Stable. And there are Hex and CUAV FC’s with bdshot firmware. Are you looking here?

Yes, I downloaded it here

Thanks Randy. I think I found the python script:

Next question, the realsense implementation uses the obstacle_distance function ( to send the distance array to Arducopter.

Is the data stored in the object database and can it be used with the enhanced bendy ruler implementation of Arducopter 4.1?

I was waiting for this release to test GSF feature, I know it’s kind of experimental still but should I give it a try to use only M8P RTK GPS as yaw source and remove the compass, I’m mostly working with multiple smaller 5 and 3 inch quad builds to fly them in guided mode only, but after many flights everytime toilet bowling effect can be seen in few of the quadcopters, and always need another compass recalibration to sort this issue out temporarily, have even tried compass motor calibration but generally there’s a lot of interference in smaller builds which always seems difficult to cope up with, still looking for some permanent solution for reliable yaw source for longer period of flight time cause I want to reduce the size further to build sub 250grams quadcopters which can fly in guided mode and always ready for plug-and-play flights without worrying about toilet bowling and need of another compass recalibration

1 Like

Hi @mtbsteve,

Yes, the OBSTACLE_DISTANCE message contents are used both for “simple avoidance” (stopping) and also for bendy ruler. Thanks for testing this!


That’s very interesting. Theoretically at least you should be able to set the EK3_SRC1_YAW to GSF and fly without a compass but this hasn’t been tested much so I suspect various pre-arm messages will pop-up. Still, please tell us how it goes.

Thanks, I will start the testing by today or tomorrow, initially will test with multiple flights with missions in auto mode, will update after some days about the results or any issues

Please note that BendyRuler has issues with beta1. Please wait for beta2 before testing BendyRuler.

I setting up a new Hex and wanted to test 32 Passthrough again and yea some odd stuff. I can get it to work in Stable tho. I not sure if this is what you mean when you say it not working.?

I see an option to flash [


is this the one to test?

This is what i am getting.

with this
I going back to my config to see if passthrough is still enabled. I also get an error using motor test until i reboot a few times. Edit: yea auto was enabled so it still not working right I think unless i need to use Master.

@Quadzilla I have not been able to physically test pixracer pro and the person who was going to went quiet, so there could easily be issues

Andy wondering am i using the right firmware? not sure if i need master to test. BTW I was able to rotate the motors. I just needed to connect a few times.

The passthrough fix is not in master - hopefully his week

1 Like

@Notorious7 you are probably seeing a temperature issue.
Can you try waiting a bit longer for the board heater to heat up the board before flying?
Do the boards you use have a board heater?
How big are the temperature changes in your part of the world?