Copter 4.0.7 crash

Hello friends. I really need your help. When flying with my copter, everything is fine, but sometimes the copter starts flying in one direction. This can happen in any flight mode. Sometimes it manifests itself during takeoff, and sometimes during the flight, and it ends with a fall like the last time. the problem is rare, reboot helps. PIXHAWK 2.4.8 on firmware up to 4.0.0 everything was fine. I have attached a log file. Help to figure out the reason for the fall. I really hope for your help.

Those 2.4.8’s are potentially a bit second-rate with their IMUs and anything could happen. Although I’m sure thousands of them are flying OK…

In this case when it switches to RTL mode pitch and roll start to deviate from desired. Probably due to trying to climb, yaw and maintain stabilty all at once.
Voltage sags a bit as current increases due to a lot of extra motor activity - the RCOUT is not recorded in logs.
One real problem is: as the battery voltage drops the Vcc also drops (5 volts DC to the flight controller) . It’s normally around 4.82 volts, which is lower than desired, then it goes lower to near brown-out level, about 4.79. This shows the power brick is not a good regulator and probably should be changed out.
Eventually the flight controller will stop working when the voltage falls enough and then you will have a total loss. You really want about 5.3v dc

I would set up the Harmonic Notch filter.
Also connect to MissionPlanner and press Alt A to set some additional battery related params, and this one:
and set this for logging:

It almost looks like you’ve run autotune on roll access but not pitch axis. If you can get the HNotch filter going then Autotune should give a really good result.

1 Like

Thanks! I will try you advice Managing Gyro Noise with the Static Notch and Dynamic Harmonic Notch Filters — Copter documentation

I tried everything as described above, made additional power, checked vibrations, added capacitors to each ESC, the error of accelerometers sometimes repeats, I suppose that this is due to the ambient temperature, the problem starts at a temperature of about 10 degrees Celsius. But strangely, I was modifying my PIXHAWK 2.4.8 by soldering the resistance and this solved the problem. The bottom line is, I went back to firmware 3.6.7 and the problem went away. on pixhawk 2.4.8 does not work stably with firmware 4.0.0-4.0.7. Later you will have to try 4.1.0 there are many fixes.