Copter-4.0.5-rc1 available for beta testing

Copter-4.0.5-rc1 has been released and within a few hours of this post should be available for download from the ground stations using their “Beta Firmwares” links.

This is a relatively minor update but includes two important fixes shown in bold below. The full list of changes is below and in the ReleaseNotes.

  1. Bug fixes:
    a) Acro expo calculation fix (fixes sluggish behaviour introduced in Copter-4.0.4)
    b) F32Lightening board IMU fast sampling fix
    c) GPS minimum accuracy added to protect EKF from unrealistic values
    d) KakuteF7/mini DShot glitch fix
    e) RC input gets additional protection against out-of-range inputs (<RCx_MIN or >RCx_MAX)
    f) RC_OPTION = 4 fix on boards with IOMCU (Pixhawk, etc). This allows ignoring SBUS failsafes
  2. Small enhancements:
    a) Linux boards accept up to 16 RC inputs when using UDP
    b) Protect against two many interrupts from RPM sensor, etc
    c) RM3100 compass support for probing all four I2C addresses
    d) Durandal telem3 port enabled

Hopefully we can keep the beta testing period relatively short (2 weeks or so) so any testing you can do is greatly appreciated!


Has anyone tried this version yet?
After installing this version and enabling DShot, the quadcopter flies very strangely in Loiter mode. It does not hang in place, constantly makes some slopes and returns to the point.

Update to 4.0.5-rc2 and provide a .bin log file.

In the release Note to RC2, there are no changes on this issue. That’s why I haven’t tried it yet.
I’ll attach the log file later…

What flight controller?

Kakute F7, flew normally before the update.

Ok - so this is because the DMA change. What do you have connected to serial1?

1 Like

Nothing is connected to serial1. The “dev” firmware version with the dshot Protocol enabled worked fine.
Link to the log file:!AgyvhCRrlh2RklZq3t33T4iO9d0p?e=iOIXhb

Ok that is very strange. Are you able to try dev from last night say? I wonder whether its one of the other changes causing this.

I’ll try to check it out tomorrow. And the log shows something?

Nothing obvious in the logs

Are you sure that’s the correct log file? It looks like the vehicle is in good control of itself in that log.

Check the timestamp in the log against when you were seeing the glitches?

The log is correct. The screenshot shows that I do not touch the controls, but the copter itself twitches.

Tentatively, it looks like a tuning issue to me. ATC_ANG_RLL_P and ATC_ANG_PIT_P values are at maximum, try lower them a bit to say 12 or 15 and see what happens.
Also these look a little odd to me, but I’m no small-quad expert by a long way:
I thought they would be closer, more balanced in terms of RLL:PIT, but your PIT values are over twice the RLL values.

You could set
plus your MOT_BAT_VOLT parameters

These parameters were obtained after running autotune, even on the first version of DEV where the DShot fix was installed.


I think you’re the author of the DShot fix for the Kakutef7. Could you re-test that Copter-4.0.5-rc2 flies OK for you and that the glitches you were seeing are gone?


These don’t look to me like the what we would see from DShot twitches. DShot twitches would likely result in uncommanded twitches as a motor momentarily spins at the wrong speed. What we see in this log though are command movements which, as @xfacta suggests, are more likely down to tuning or environmental issues.

Sorry to keep asking you to re-test but could you do back-to-back tests of 4.0.4 and then 4.0.5-rc2? It’s important that the environment is similar between the two flights.

The important thing in terms of getting the release out is that 4.0.5 doesn’t have any regressions from 4.0.4.

Sure. I will test it

1 Like

I have tested 4.0.5-rc2 with kakute f7 & tekko32 4-in-1 rsc. Fly 4 full batteries in althold, indoor and everting is fine

12 1980-1-1 (938.2 KB)
14 1980-1-1 (969.1 KB)