Copter-4.0.4-rc4 available for beta testing

Copter-4.0.4-rc4 has just been released for beta testing and should appearing in the ground stations (MP, QGC) within the next few hours. Compared to the previous beta (4.0.4-rc3) this release includes the following bug fixes (Release Notes):

  1. Bug fixes:
    a) Compass startup reordering based on compass priorities fix
    b) TradHeli servo test fix
    c) Precision landing logging fix
    d) Mavlink commands ignored after reboot request

The first one is the most important and involves a problem we found with the new compass prioritisation code. In short we found that after the compasses were moved around in the MP’s fancy new compass prioritisation table, the COMPASS_DEVIDx parameters were not being re-ordered properly. This didn’t cause any troubles in flight but it was very confusing for support when trying to figure out which compasses parameters were being used for which device.

Surely this is the final beta so any testing is greatly appreciated!


no problem till now on basic functionality, different flight modes, failsafe and command from GCS
i still didn’t test auto mode and auto-tune

another grate work from Dev Team

1 Like

I was in AC 4.0.4 rc3 with cube black and HERE 2 I have set compass priority 1 to here2 compass HMC5883.there was no issue with compass detecting and priority orders at N number of boots.

But after I uploaded to AC 4.0.4 rc4 the here2 compass not detecting .again I was tried with beta rc3 version same issue continues . whether it’s hardware issue ?

i just saw there’s a new manual for the proficnc Here3 and (updated?) instruction for Here2 on their website, instructions about compass are referring about a screen in mission planner which gives you compass interfaces (can,SPI…) and reordering option. are them all things of master-dev 4.1.0? I’m using 4.0.3 and mission planner 1.3.72 and cannot see them


Yes, the new compass prioritisation feature is included in Copter-4.0.4 so if you load up the beta you should be able to try it out. The latest mission planner may also be required.

thanks Randy, tried it, as you said, works as expected

1 Like

Basic flight tests performed OK after upgrading from 4.0.3 on FMUv2
All worked as expected, although we dont use CAN devices or anything special on this quad.

1 Like

Hey just a dumb question…I am good at those.
I loaded the Beta 4.0.3 code and got that cool compass sort interface. I love it and it helped solve a problem. I then loaded the gold code and the sort function was gone…huh…what the.
I then loaded the 4.0.4 beta and it was back.
Is it me, am I missing something.

In the mission planner on the compass setup screen it does not show the correct compass orientation. On the full parameter list my compass COMPASS_ORIENT is set to yaw 90.

Arducopter 4.0.4 Traditional Heli
Mission Planner 1.3.77554.21463

Any plans for the official release date?

Hi @rickyg32,

Sorry for the slow reply. The new compass prioritisation code relies on some new parameters that are only in Copter-4.0.4 so it makes sense that if you went back to stable the prioritisation feature was gone. What’s perhaps confusing is that even when you go back to 4.0.3 (stable) the last recorded value of these new parameters is kept in eeprom. This means when you upgrade to 4.0.4 again the prioritisation you’d set previous is used.

Thanks for testing!


Thanks very much for this report and sorry for taking so long to respond. I’ve reproduced the problem and created an issue for the Mission Planner. I suspect this is just a display issue but we shall see.

@amilcarlucas, I was hoping to release Friday or Today but I’d like to get to the bottom of this issue first.

Of course It would be good to fix this issue, but 4.0.4-rc4 contains other fixes as well. I expect it will reduce the support efford once it is released as stable.


Michael Oborne has released a new beta version of MP with a fix for the Orientation. I’ve asked if he can get a stable MP released with the same fix in the near future. Thanks again for finding this issue.

1 Like

It seems like a new MP stable release has been published.

Mine just updated on boot a few minutes ago.


Even so. I can’t say if this new versión is the one that solves this bug. Anyway, the changelog for MP seems to confirm that point.



Can Copter-4.0.4 stable be released now?