Servers by jDrones

Copter 4.0.3 on Pixhawk 1 (2.4.8 clone), BLHeli32/Dshot issue. Bad serial, or Aux out?

As stated. I’m on version 4.0.3 on a Pixhawk clone (2.4.8). I’m using Holybro Tekko32 F3 ESC’s on a S500 quad. Using BLHeli 32.7.1.3 and Mission Planner 1.3.71. Settings listed below.

Problem is: While I can get the ESC’s to be recognized by BLHeli32 on AUX 2,3 and 4. I cant get any of them to be recognized on Aux 1. Also, the ESC’s are showing up on channel 6, 7 and 8 in BLHeli32. Nothing on 5. And Channel six shows as “Master” and the others show as “slave”. Or, if I plug them in one at a time, they each show up as “Master”. But still noting on AUX1/channel5. I can still program them individually, using AUX 2,3 or 4. But they SHOULD work together, right? The motors will spin when using “motor test” in Mission planner, as well as by remote controller. But they don’t spin very fast. And slow down over time, even at full throttle. But otherwise seem to work fine.

I have all four motor telemetry outs summed into “Serial 4/5”, pin 5. And of course, motor PWMs on AUX 1,2,3 and 4.

Mission planner settings:
Serial5_Protocol set to 16 (ESC Telemetry).
Servo_BLH_Auto set to 1.
Servo_BLH_Mask set to 3840.
Servo9_Function set to 33.
Servo10_Function set to 34.
Servo11_Function set to 35.
Servo12_Function set to 36.
All other servos set to 0, but Servo 5,6,7 and 8 keep showing up as 37,38,39 and 40.

Any ideas what’s wrong here?

Frame_class set to 1 (quad)? You wouldn’t be the first to have Octo Quad set by mistake. 8 motors are assigned as you say. Or post your parameter file if that’s not it.

You were right. I know I originally set the frame to quad X. But somehow it was on Octoquad. Maybe from the update to mission planner.

Anyway, that fixed the motor numbering problem in mission planner. However I still have an issue in BLHeli32. The motors are now correctly numbered 1 through 4. But Motor 1 / Aux1 still doesn’t show up. I have to move the connector for that ESC to another Aux port (2,3 or 4) to see it. Not a big deal, I guess. As before, I can still program them one at a time. But it’s weird. Anyway the motors test fine in mission planner, as well as radio control test. So I think it’s okay. I will continue to follow the wiki for final set-up and tuning.

Param file attached, if you want to look at it. And thanks for the help.

S500 quad.param (18.0 KB)

I don’t see anything in the parameter file to indicate a problem and if the motors run in Mission Planner’s Motor Test as expected you should be good.

Servers by jDrones