Copter-4.0.2-rc3 available for beta testing

Copter-4.0.2-rc3 has been released for beta testing and should be available for download using MP’s beta firmwares link (and probably QGC’s as well) within a few hours of this post.

Due to a couple of missteps during the release procedure we’re jumping immediately to -rc3. Please just make sure after you load the firmware on the vehicle that it says “ArduCopter V4.0.2-rc3”.

The changes vs 4.0.1 are in the ReleaseNotes and also copied below:

  1. Bug Fixes:
    a) AutoTune fix to restore original gains when AutoTune completes
    b) IO CPU timing fix which reduces ESC sync issues
    c) PX4Flow driver probes all I2C ports on Hex Cubes
    d) RangeFinders using PWM interface (like Garmin LidarLite) use RNGFNDx_OFFSET param
    e) RC override fix when RC_OVERRIDE_TIME=-1 (allows disabling timeout when using joystick)
    f) TradHeli attitude control parameter description fixes (does not affect flight)
    g) cygwin compiler fix (affects developers only)
  2. Minor enhancements:
    a) GCS failsafe warning lights and tones
    b) Circle mode pitch control direction swapped

The first and second bug fixes are probably the most important but we’d love to hear back from beta testers re any of these or other issues you’re facing. I’ve put a few names below that have helped us find issues but there are others too and we really appreicate it thanks!

For 1b (IO CPU timing fix), if @Christian81, @Jimmy_Oliver and RickReeser can confirm this version resolves the issues they have seen that would be great (Jimmy has already confirmed on a test version so it should be fine but just one more check that it’s OK in the beta would be great).

For 1c (PX4Flow driver) and 1d (RangeFinders using PWM), maybe @mtbsteve you could give it a try and confirm it’s OK?

For 1e (RC override fix) could @rrr6399 you confirm this is OK? Thanks again for finding and fixing this issue!

For 2b (Circle mode) maybe @JoshW, @winstonsaz, @wn0x could confirm they’re happy with the pitch direction change?



Thanks Randy! This sounds great, I’ll give it a go this weekend but I’m sure it will be great.


Hi Randy,
I am testing arducopter on my new FC MATEK F405 CTR for the first time, but the buzzer is not working. I don’t know if it’s a problem with my new FC or with Copter-4.0.2- rc3.

1 Like

Nice , i just downloaded the rc2 some hours ago. :grinning:
Since I was on the 4.0.2dev the currend (pin3) did not work anymore on my MiniPix compared to 4.0.0. Will see how 4.0.2rc3 works.
I hope this is fixed.

1 Like

Just uploaded,it went fine will test tomorrow,thanks for all the work you do

1 Like

I just took 4.0.2-rc3 for spin on a:PixRacer and everything performed well. No Auto Mission as it’s snowing but everything else worked as expected. The Circle Mode Option feature is cool.


Dave thank you,I forgot about the circle feature so much to keep me busy and have fun Ye He im the happiest old age pensioner in town,and Randy im owe you a Large Suntory Whisky.

I had not tried it before but saw it in the beta update so decided to check it out. Cheers Marty!

1 Like

Verified the tones and lights for the GCS Failsafe are working as intended.

1 Like

Hey @rmackay9, on TradHeli today I still had the seemingly-reversed version of Circle, where when I pitched “forward”, the radius would increase, and when I pitched “rearward” the radius would decrease.

On the FC MATEK F405 CTR I have baro bad health if RGB led connect to led pad on FC

Hi Randy,
unfortunately a negative on the RNGFND1_OFFSET fix. Still the same behavior with 4.0.2RC3 like with 4.0. Any inputs for the offset are ignored. (its working well with AC 3.6.12 NuttX)

The PX4FLOW seems to work now, at least I get non-zero readings now for opt_m_x, opt_m_y and opt_qua.

Other issues and observations:

  • Battery voltage is displayed on the GCS (MP, QGC and Solex) about 3 volts higher than in reality (voltage meter mesurement). AC 3.6.12 displays battery voltage correctly when I downgraded again.
  • Altitude is always zero via FPV telemetry but ok on the GCS. Is working well with AC 3.6.12. It seems like the DEV_OPTIONS parameter did not get migrated during the update - I had to set it manually to 3 (Dev_OptionVFR_HUDRelativeAlt was disabled)
  • also ADSBMavlinkProcessing was disabled in DEV_OPTIONS - could this be a reason that others were complaining about no aircraft detected?

@rmackay9 Willing to test this if you think it helps as there may be other esc sync issues. I started another thread to find out as it could be something I am missing in setup.


Thanks for the report on the RNGFND1_OFFSET. Indeed there’s a problem with the change so this will unfortunately mean we will need an -rc4. Thanks for the report though! I might come up with a test build so you can give it a try earlier than the next release candidate.

I’ll have a look into the other issues you’ve reported as well. The battery voltage one surprises me but I have two theories:

  1. the scaling parameter values are different between the two versions. This can happen because we only do the parameter conversion once so if the vehicle is moved back and forth between the versions. We can check this if you’ve got an onboard log on 3.6.x and 4.0.x.
  2. one version is reporting a sag compensated value and the other is reporting a raw value.

Thanks for the report. I wasn’t aware of this issue and it wasn’t on our Copter-4.0 issues list so I wasn’t tracking it. I think it’s very unlikely to be resolved in this beta but hopefully one of the other devs can tell me which patch we need to back-port to get it working.


Could you try this firmware for CubeBlack to see if it resolves the PWM RangeFinder offset parameter issue?

@rmackay9 are you likely to merge my dataflash fixes? I can do a separate PR if it helps.


I was planning on including them in a point release but perhaps not 4.0.2 because we’ve got this serious AutoTune issue to get out. If it’s not in master yet then we should probably tag it as a DevCallTopic so that it gets reviewed at the dev meeting tomorrow. If it’s already in master we just need to set it’s project to, “Copter-4.0 backports” and then I’ll remember to merge it into the next point release.

Hi Randy,
4.0.2dev fixes the problem with RNGFND1_OFFSET. That works now as in 3.6.

However the voltage and Current scaling issue still persists.
Here is an image showing the real values measured with a Jeti sensor and the measurements of AC 4.0.2dev coming from a 3DR sensor. Again, in 3.6 the voltage measurements of the Jeti sensor and the 3DR sensor are equal.

Here is the link to the log file:

EDIT: Link to 3.6.12 log added:

Next problem:
With AC 4.0.2dev, there is NO telemetry anymore to my Jeti RC. Something must have been broken from 4.0 -> 4.0.2dev.