Copter-4.0.0-rc3/-rc4 available for beta testing!

Thank You @rmackay9 :slight_smile:

same thing this time resulted in a crash, gps set to default

Hey @rmackay9
I just saw the updated GCS failsafe documentation done. Nicely done. I’ll be doing couple of flights tomorrow. Let me know if anything has to be tested specifically.
Thank you :grin:

1 Like

Where are you tying to fly? The last log showed very poor GPS performance. Are you trying to do this indoors in dense tree cover? That’s going to happen to anything using a GPS.

no, in wide open space about 2000m amsl :slight_smile:

When I test using the simulator, I’m seeing MAV_SYS_STATUS_SENSOR_XY_POSITION_CONTROL and MAV_SYS_STATUS_SENSOR_Z_ALTITUDE_CONTROL flags set in the msg_sys_status.onboard_control_sensors_health. Is that just a bug in the simulator?

Maybe a flow sensor and lidar is enabled by default, but not implemented. I’ll check the parameters.

dear friends,
today i flew a lot the new software. theire were some things i would like to mention.

  1. The copter nearly crashed into me. It was me who made the mistake but the reaktion of the copter was in my eyes to dangerous.
    What happens was: I upload a mission, terrain follow with the Lidar. Terrain_enable to 0 (of cause i want to use the Lidar) RC9_OPTION: RC input option i put to 10 to enable / disable Rangefinder.
    So, I start and when I put the kopter in Mission i didnt had the Rangfinder on and the kopter was flying highspeed to the position I stood. He was mention something like FAILSAFE_Terrain DATA Missing.
    Sure, my fault, but it was very close to an accident

Log# 41

  1. since I use the 4.0.0. firmware (rc2, dev, rc3) I got a lot of times the error message, while the copter is standing PREARM: EKF2 Yaw Inconsitent by xx degree. This Message I never got before with th firmware

Log# 38

  1. during mission suddenly with no reasons the kopter was suddenly shaking and the ekf change from 2 to one. I flew him back in position hold but he was very unstabile. Look please at

Log# 43

  1. after that i flew for filming the kopter with another kopter 2 missions with absolutely no problems

Log# 44 / 45

1 Like

Hey @rmackay9
Did a flight test today. I added ESC telemetry before going to fly today. I’m able to receive all ESC parameters except for Current values.
I noticed there was problem 3 times today where board didn’t boot after connecting battery. It just goes blank with power LEDs ON and AP doesn’t boot after that(no boot sound too). Probably boot time issue?
I’m trying to record video of it, but its kind of not repeatable.
There was no issue with flying. I changed my Mag position a bit, You might notice a bit higher offsets in the log.
Tried AutoTune just to check whether it was working fine and it works.
Auto Missions work well too. I even pushed the aircraft to max bank angles and Ardupilot handles it well.
Thank you.

1 Like

Thank you very much, looking forward to it.

GPS no work with 4.0 RC3 on OMNIBUS f4 PRO. Mission planner says: no GPS. With RC2 works well … same hardware.
how can I do? Thanks

All OK on omnibus nano. Stabilize and auto both working great.

1 Like

Issues so far on Orange Cube:
Second onboard MAG is not correctly detected:

Mag calibration was a nightmare. It took 10+ attempts for a calibration to succeed with internal + external. External being a Here2 I tried with both 0 and 1.17 in _SCALE. It didn’t help. And checking params, seems that calibration started messing around with _scale as well, as I’ve seen external go 1.23 and internal 1.05
FrSky passthru starts off the bat, as I reported before, but works only with external port inverter. SERIAL_OPTIONS 7 still won’t work. Tested on serial 1, 2 and 4 (telem1, 2 and gps2)

My motors are still mapped on Aux channels and set to DShot600, but logs still show PWM values in RCOUT

I flew 6 Batteries today. No issue at all with a 3DR Pixhawk. I tried:
Calibration processes
Stab, altHold, position hold, auto mode
Yapuu telemetry
Dynamic notch

Copter flies mucg more stabil compared to



1 Like

@Alberto_Ds, we haven’t made any changes to the Omnibus f4 Pro between -rc2 and -rc3 so it’s not clear why the GPS would stop working. Could you please include a dataflash log so we can investigate further.

@hwurzburg, do you have an omnibusf4 pro? If “yes” could you double check that your GPS is working?

@rmackay9 what is Copter-4.0.0-rc4 ?

@zhangsir, All,

We’ve just released 4.0.0-rc4 with three additional changes on top of -rc3:

  1. Compiler updated to gcc 6.3.1
  2. Solo default parameters updated
  3. Bug Fix to RCMAP channel number sanity check

The first change is the most important but nobody should actually notice a difference. Still, we couldn’t risk releasing 4.0.0 next week using a different compiler from what was used during beta testing.

Sorry for causing confusion by releasing -rc4 without a separate announcement but should be just a minor change on -rc3.


Hey @rmackay9
Uploaded rc4 and pixhawk lights went solid blue. I know both here1 gnss and pixhawk LED are on I2C line. I don’t why only here1 LEDs are working fine and not pixhawk one. Pixhawk lights are fine after reboot. And Compiler update is 6.3.1 or 7.3.1?

roger that !

thanks you .

Specifically gcc-arm-none-eabi-6-2017-q2-update

1 Like

There was an update to the bootloader for the H7 boards. You might want to try reflashing your bootloader - no idea if its related, but FYI.