Copter 3.5 rc7 autotune does not start - help!

trying to start autotune in 3.5 rc7 with no result. it changes the mode but no “dance”

Which mode did You use when starting AUTOTUNE ?
Had the same … Then did it in PosHold with centered stick (throttle) … Worked fine.
You have to wait a little for the dance … Does not start immediately !

Tried so far alt hold and loiter. Maybe 10 sec waited. Previous version rc5 pos hold was prety good now it is drifting alot.

The most common reason it won’t start is because the sticks aren’t perfectly centered. A few other people bumped into this so I added a section to the wiki:

We are also increasing the deadzone on the sticks a bit for -rc8 which I plan to release out today.

Thanks for testing!

Since then i have done couple test with rc8

rc1234 dead zone was incresead to 50.
pid where lowered
no way of making it start autotune.

Also can you point to where can i download the Copter 3.5-rc1 compiled ?
Plan is to try autotune with an older version and change back to rc8 and retry autotune

Thanks for your help!

DZ is not a problem here, try this: I’ve seen it help sometimes:
you tune roll axis, do a fast input on the roll stick, only 10-15% of the travel, enough to cause a small twitch, and let it quickly go back to center , you can expect to “trigger” one of the tuning twitches. - repeat …
I’ve used that method on a huge octo that did not want to twitch unless I did that.
I suspect your Z vibrations could be the cause, I also had some more z vibrations on that machine than I would like to have. (thanks to big folding props)

Thanks Andre-K,
i have observed this motion, question is, have you done this till the end or just to start the "dance"
Also seen a suggestion to lower the filter for roll and pitch to 5hz instead of 10hz. Have you tried that ?

I have successfully completed a tune of one axis by that method.
Yes, I’ve reduced filter too prior to that, not sure I went down to 5Hz, but at least 10 or 8. that did not help - I think. But you should try.


Maybe check if you have trim values setup in your parameters or on your rc transmitter.

I had similar issues for a while until I realized that i had trim values both in the parameters and on the rc - when I removed them (set to zero) things improved.

The other thing I noticed that autotune worked more reliable when I removed the anti-vibration dampening mount and attached the pixhawk directly to the frame.