Copter 3.5 beta RC2, Tricopter, Pixhawk mini, Same problems as RC1

I posted this about 2 weeks ago: Problems w/ Copter 3.5 Beta RC1 Tri on Pixhawk mini

Problems are similar from RC1 to RC2.

ESC calibration ALMOST works. I have to fool with the ESC_Calibration parameter but the tail motor does nothing but beep. I get calibration tones from motors 1 & 2 (depending on the ESC_CALIBRATION setting) but the tail motor doesn’t ever enter into calibration mode. Also, I get no calibration tones until AFTER I disarm. I raise throttle, plug in battery, wait for tones, unplug battery, plug back in, wait for tones, arm with button, get the bad beeps from tail, disarm & hear calibration tones from front motors. I have done a proper calibration with arducopter before so this is a mystery.

Also, still no yaw from the tail servo. I have everything wired right. I don’t have these problems on PX4 but that firmware has it’s own bugs related to tricopter. Arducopter is better overall.



For TriCopters you should use the multicopter firmware (i.e. Quad) not the helicopter firmware. This could explain why the ESC calibration wasn’t working and why the FRAME_CLASS parameter kept changing back to 6.

I’ll update the tricopter wiki page today I think.

I must admit, that is confusing. It seems it confused the good folks of QGroundControl as well.

There are only 3 firmware options to download for RC2 on QGC: Heli - APM:CopterV3.5.0rc2 then there is Plane & Rover, which my tricopter is not.

Is there a place I can download the firmware without building it myself? Cannot find via google. QGC wants a .px4, .bin, or .ihx file. I downloaded copter 3.5 rc2 from & got plenty but not what QGC wants.

Sorry, I am a hardware guy, not a firmware guy. I build airframes.



Ok, there’s an issue with QGC and Don Gagne knows about it and hopefully he’ll fix it soon-ish. The issue in case you want to track it is here:

Until then you can get the firmware from here:

You’ll want the ArduCopter-v2.px4 that’s there.

Ah I came across the same bug, I thought this was the newly merged copter firmware so loaded it. It’s worth noting that after I turned everything on, after a while the motors started turning at a reasonable pace even though I hadn’t armed it (and it would have failed prearm checks as I was inside and hadn’t calibrated it). Happened twice, then I realised I must have loaded the wrong firmware and loaded the correct one from the firmware site. Fortunately I always take my props off inside!

Thank you very much!

Final question: When I click the link you specify & try to download, I get a webpage filled with ascii. Do I copy all that into a text file & save it as .px4?

I don’t want to brick my mini, so asking just in case.


The QGC issues here: isn’t related to not being able to get the corret firmware. That is most likely caused by running a stable build which does not know about the firmware server format changes. Can you try runnning a daily build instead and see if you see all firmwares? Daily builds know about the new server format.

Where are the daily builds?

Links are at the bottom:

If you need and Android daily let me know. Those are out of date right now

@megabotz69 Kyle, use your right-click in the file and Save as instead of left-clicking it.

By the way, I update the tricopter wiki page.

I tried the daily build of QGC last night but no new firmwares.

I was able to “save as” & load a custom FW through QGC & now have copter 3.5rc2 on my pixhawk mini tricopter.

ESC calibration still not going the same as the instructions but that is probably its own thread. I will keep fooling with it & post results.

Thanks for all the help!


Here’s a short video that shows the issue on QGC and that you must reselect the first drop down box to multicopter, after choosing master…

It was beta that had only heli, plane & rover available. I certainly checked the upper drop-down box after selecting beta. There were only 3 options.

Happily, downloading the FW as described above allowed me to install the proper FW.


Where are you downloading daily builds from and what OS?

I used the link you replied with above. That was a few days ago, though.

Windows 10


Can you post a screen shot? Of the dropdown you get?

I apologize that it took me this long to get this posted.


Nevermind, I figured it out. I didn’t scroll down far enough.