Copter 3.5.5 weird Yaw problem

Hi guys,

We’ve been using a pixhawk with copter 3.5.5 firmware on our quad and have been having random yaw problems. I have attached a log file here. Takeoff was in position hold and there was a sudden un-command yaw. Trying to yaw left or right resulted in almost no response/very poor response. This quad has flown numerous missions and flies very well otherwise. Can anyone help as to whats happening here?

Here’s the log file:


Hi Guys,

Has anyone been able to look at the log? Is more information needed to figure out what the problem could be?


Too much vibration, especially in the z axis.

Actual movements when graphed against desired would indicate this copter hasn’t been auto tuned. Has it?
If it has, maybe you should reduce the aggressiveness and do it again.

RCout is the most telling, as it is all over the place.
The motors are having to shut down a lot to maintain attitude.
This will cause all sorts of issues, the yaw response being one.

Give a description of your quad. Size, motors, all-up weight. The motor pumping that Mike has graphed may be telling of issues correctable with some filter settings. Kind of hard to believe actually that it flies “very well” with these motor commands.

Hi Mike, Dave,

Thanks for your inputs. I’m surprised you say vibrations are high. I’ve been following the copter docs and according to the measuring vibrations page, a plot of VibeX, Y and Z should reveal vibration problems. It says values less than 60m/s/s are acceptable. I have attached the vibrations plot for this log here, and the vibe levels seem very low, or am I seeing something wrong here?

Also, an auto analysis of the logs reveals that motor 3 and 4 always seem to be running slower, and the analysis flags a motor imbalance warning:

Log File C:\Users\DCE\AppData\Local\Temp\tmpF22C.tmp.log
Size (kb) 4429.240234375
No of lines 51643
Duration 0:02:38
Vehicletype ArduCopter
Firmware Version V3.5.5
Firmware Hash 27229c83
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (9.03%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.28, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = WARN - Motor channel averages = [1481, 1440, 1394, 1354]
Average motor output = 1417
Difference between min and max motor averages = 127
Test: NaNs = GOOD -
Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - ‘THR_MIN’ not found
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = GOOD -

From what I read, this could be because of a slight miss alignment of the motors, or ES calib. The ESC’s have all been calibrated together and seem to run fine and in sync unload. The Pulsing effect also is most visible in motors 3 and 4, according to the RCOUT plot.

The quad weighs about 1.8kgs, and has 400 KV motors spinning 13" props running on 5S batteries. It has not been autotuned but been manually tuned. I’ve used arducopter for a number of years now. I will autotune now only if I have more clarity on the vibration levels and why the motors are imbalanced.

Dave, what filter settings should I look at?

The default filter settings for that quad may be OK. If it’s a small quad or a very large quad then the filter settings can be significant. You have all of these set to default which for that size craft has worked OK for me.

Thanks Dave. Any suggestions on the vibs? Should I look only at the raw acc readings ( z axis within -5 and -15 and x and y within ±3 ) like in the older versions and not look at the new VibeXYZ messages?

Your vibe levels look OK to me. I was asking about the filter settings in case this was a smaller, or very large, quad. It’s neither so I would think the default filter setting should be OK. I have a 550 size quad similar to your setup on 6S and they work.