Copter-3.5.0-rc9/-rc10/-rc11 has been released for beta testing

Copter-3.5.0-rc9/-rc10 is now available for beta testing and should appear within the next few hours in the Mission Planner’s (and other GCS’s) beta firmware’s link. This is just bug fixes and minor enhancements over -rc8 (Release Notes):

  1. AutoTune improvement when using position hold (twitches in body-frame instead of earth-frame)
  2. GPS fixes:
  • RTK GPS fix when large RTK correction messages are sent
  • auto-detection for NMEA disabled (NMEA users must explicitly set GPS_TYPE to 5)
  1. EKF bug fixes:
  • fix bug preventing use of optical flow for terrain height estimation
  • fix bug affecting accuracy of optical flow estimated height during climb/descent
  1. return accel filter (INS_ACCEL_FILT) to 20hz (some users were seeing oscillations at 10hz)

UPDATE: -rc10 includes these two small changes on top of -rc9:

  • Intel Aero build and default parameter updates
  • EKF final yaw reset lowered from 5m to 2.5m to speed up bad compass detection after takeoff

UPDATE: -rc11 includes these three small changes on top of -rc10:

  • Re-enable auto detection of NMEA GPS (revert change from -rc9)
  • Fix SBF race condition on start (this should resolve SBF GPS detection issues for some users)
  • SF40c driver fix to ignore zero distances

For those who have discovered potential issues during testing, please create a new topic in the Copter-3.5 category and if possible include a dataflash log file (aka a “.bin” file).

If no critical issues are uncovered we are planning to release -rc9 as the official AC3.5.0 within a week or so. We have a few known issues that we plan to tackle in follow up “point” releases (i.e. AC3.5.1):

  • Spektrum receiver binding problems (discussion)
  • Pixracer DSM receiver can lead to input corruption (discussion)
  • enabling UAVCAN leads to “baro unhealthy” message (discussion)
  • OLED display’s “EKF: ok” always says ok (issue14)
  • Slight delay in turning to next waypoint (discussion10)
  • Mission-Clear-All from QGroundControl is failing 50% of the time

If you think I have missed some critical issues and want me to look into them further, could you reply to this thread with a link? I’ll jump on them and re-investigate.

Thanks again for helping with the testing, we’re almost there!

P.S. Sorry, if I’ve been a little slow answering support requests, I’ve cleared a hurdle recently with the 3rd semester of the DroneSchool completing so I should have more time from now on.


I know this has been asked several time but can we plan for JR XBUS support? I heard the users are not as much but would help those of us stuck or invested into it.

Hi vkt62,
It’s apparently already on the to-do list but has been there for a very long time, sorry!

1 Like

I have an error with 3.5.0.-rc9 on pixhawk lite hardware like as below

“PreArm: Logging failed
No IO Thread Heartbeat
PreArm: Check FS_THR_VALUE
PreArm: Logging failed
PreArm: Check FS_THR_VALUE
PreArm: Logging failed
No IO Thread Heartbeat
PreArm: Logging failed
PreArm: Check Board Voltage
PreArm: RC Roll not configured
PX4v2 00450029 31345101 35313935
Frame: QUAD
PX4: 33825946 NuttX: 1a99ba58
APM:Copter V3.5.0-rc9 (242c8f0b)
PreArm: Logging failed”

Maidened and tuned my test platform today (PH2.1 and rc9) all went smooth, autotune worked like a charm. Thanks for all developers for their hard work !

1 Like

Today, a calm day I try my medium size cuad to autotune (701kv 14*4.7 props) I update from an old firm and begin from default; , did little manual calibration, verify that I can hold altitude, move side to side and switch to autotune in pos hold, looks nice, much less space to tune than other times and very fast, I can try 3 times hole process with the same battery (14 mins total). As soon as I have little more time I test flying. Thank´s Devs. :slight_smile:

1 Like

Flew a number of batteries with RC10 on my Solo today - everything works perfectly fine.
Also with a Lidarlite V2, connected via I2C, no problems.
Thanks to the entire dev team for their great work!

My only remaining problem is with IR-LOCK precision landing in combination with 3.5. If someone could have a look at the logs I posted in a separate thread here. Thanks!

1 Like

I’ve been running AC3.5 rc’s for a while now and I’ve been eagerly awaiting the final release. In the mean time I’ve had to step away for a little while, so I fell behind and stopped at rc-7.

Today I discovered that rc-11 was out, so I took one of my two Pixhawk aircraft and flashed it with rc-11. HUGE mistake. Data logging is broken BAD…

Its not my SD card. I’m using a 16 gig class 10, and it works just fine in the Pixhawk that is still running rc-7. I also tried the 4 gig class 10 from the good Pixhawk, same issue.

To further verify this is not a hardware issue I flashed the sick Pixhawk with AC3.4.6, and it works just fine. Of course my OLED display is non-functional, but at least Craft & Theory Flight Deck telemetry, retracts, and the STorM32 3 Axis gimbal still work.

What really trouble me is earlier today I read that AC3.5 final may be released shortly, and I sure hope Y’All get this logging issue resolved ASAP…

Hello, testing the motors using motor test in a coax octo makes motor B to turn with the rest of the motors.
It means that if i send motor A move motor, then motor A and B will turn (in fact motor B turns all the time i send motor start)