Copter-3.5.0-rc8 has been released for beta testing

Copter-3.5.0-rc8 has just been released and is available through the Mission Planner’s (and other GCS’s) beta firmware’s link. This is just bug fixes and minor enhancements over -rc7:

  1. Solo on Master:
  • add/fix tones and LED support
  • resolve dataflash health reporting issue
  1. Allow flight controller to boot even if critical sensors fail (previously stopped at startup and displayed message people could rarely see)
  2. Minor enhancements:
  • Landing Gear retracts/deploys only when pilot first moves switch (previously would always deploy on startup)
  • BeagleBoneBlue supports external compass, OLED display
  1. Bug fixes:
  • increase pilot stick dead zones for roll, pitch and yaw (still slightly more narrow than AC3.4)
  • increase default roll, pitch and yaw rate IMAX values to 0.5, reduce default yaw rate filter to 2.5hz
  • reduce accel filter from 20hz to 10hz (smoothes throttle in AltHold)
  • fix EKF declination fusion
  • object avoidance fix to ignore old distance measurements and out-of-range distances from range finder
  • fix poxyz west-east processing (it was backwards)

For those who have discovered potential issues during testing, please create a new topic in the Copter-3.5 category and if possible include a dataflash log file (aka a “.bin” file).

I think we are very close to the final release now. I think we have identified these outstanding issues but it is debatable whether they all need to be resolved before go-live.

  • Spektrum receiver binding problems (discussion)
  • Pixracer DSM receiver can lead to input corruption (discussion)
  • enabling UAVCAN leads to “baro unhealthy” message (discussion)
  • OLED display’s “EKF: ok” always says ok (issue)
  • Slight delay in turning to next waypoint (discussion)
  • Mission-Clear-All from QGroundControl is failing 50% of the time

If you think I have missed some critical issues and want me to look into them further, could you reply to this thread with a link? I’ll jump on them and re-investigate.

Thanks again for contributing to making this a solid release!


Yay! I will get this out to the Solo beta testers this evening!

1 Like

The arducopter crashes on erle brain board constantly, without being armed and at random time. Could there be compatibility issues?

Just returned from a few testing flights with RC8 installed on my Solo.
RTH, RTM, Smartshots (with the modified python files from @Pedals2Paddles), LED and tones, dataflash logging, battery monitoring,…
Very pleased- All good!

1 Like

Thanks for the report. I’ve added this to the critical list and I see Lucas is working with you.
Are there any NAVIO2 users out there? Having similar problems or is NAVIO2 ok?

I rebuilt everything again and it still kept happening.

Hi @rmackay9,

I’m building it for my Erle-Brain 3, I will test it.



Do We have to redo autotune cause of filters changes?

@cala2 i saw that my I values weren’t close to the new IMAX, so if yours are at max then yes, your tune would change.

@rmackay9 @Leonardthall

I hadn’t flown my tricopter since 3.3, so i am a bit behind. I reconfigured everything from scratch, did autotune 2 times to get a nice tune (i always do that and i feel like the first tune gets it close, but the second tune ontop of the first gets it all the way).

Position Hold

600mm Tricopter Frame
10x4.5 propellers
2216 800kv motors

I think the new release will be amazing, and i love the new position hold autotune, makes life sooo much easier. It’s pretty cool to watch it turn into the wind and in the yaw part of the tune do a little circle maneuver :smiley:

Thanks to all the guys that make this firmware possible, sorry you guys had such troubles last year.
Thank you Randy <3
Thank you Leonard Hall <3 (i think you did the tricopter specific improvements, sorry i didn’t test until now)

1 Like

Hi Cala,
No you should not have to change your tune with the filter or I MAX default changes.

1 Like


First try with Navio2 and 3.5rc8 today.

Stabilize is OK, Altitude Hold and Position Hold OK, RTL is OK.

Here is an onboard video:



Myself and several others have loaded plain old RC8 onto our green cube equipped solos. No custom build, no baked in defaults from ROMFS. Just 3.5-RC8, and load the required parameters. It’s flying great!


I am still having same seg fault on different Erle brain3 consistantly :frowning: The 3.6 dev version would have the same issue too. Tried running with gdb(no issue), running with --debug version (no core dump file generated), so I am not moving forward… Hopefully this problem could be resolved soon.

I flew again yesterday with rc7 and twice had the “home location updated” message while in flight. At RTL the copter tried to go back to the flight location, not the arm location. Is it just me?

Did you take off before the GPS was ready? That’s what happens if you do that.

No. I always wait for ready to arm in PosHold to avoid that issue.

Strange. Can you post the dataflash log to be looked at here. Also, your post says RC7, but we’re on RC8 now. @rmackay9, this looks troubling, but never seen anyone else have this happen before either. What would cause the home location to change multiple times in flight?

Same here (“home location updated” message while in flight), some weeks ago on a small pixracer quad. Will check I find a log and make a test with rc8.

Can one of you create a new post in the 3.5 forum for this issue? Please include details such as what vehicle, what flight controller, what firmware, and post dataflash logs.