Copter-3.5.0-rc4 released for beta testing

Copter-3.5.0-rc4 is being released for beta testing over the next few hours (at the time of this post, the auto-builder is still working on it). This has mostly minor bug fixes over -rc3 which are listed below and in the ReleaseNotes.

  1. Bug fixes including:
    a) Baro based altitude estimate fixes including limiting ground temperature to reasonable value
    b) Fix 0.6ms lag reduction
    c) Fix Invensense IMU driver temperature reading
    d) Fix semaphore take during interrupts that may have caused very occasional main loop rate issues
    e) Return the Home position if GCS asks for first (i.e. zero-ith) mission command (required for Solo)

1b) may lead to a slight improvement in attitude control especially for small vehicles. This changes was meant to be included in -rc3 but due to a small misunderstanding -rc3 actually had slightly worse lag than previous versions.

1d) may resolve the one ugly crash we saw in which a Pixhawk1’s performance degraded over about 30 seconds. Unfortunately that issue appears to be so rare it may be difficult to know if we’ve solved it.

1e) is for the project to get Solo running on master again.

Thanks for help with the testing! I’m pretty sure we’re almost there.

3 Likes

minor misprint I believe: “This has mostly minor bug fixes over -rc3 which are listed …”

My friend the analog sonar EZ0 Does not work from version 3.5.0-rc3,

Would you have the link for me to download from version 3.5.0-rc2?

I am developing for my college a decision making for pixhawk when the same find an obstacle using sonar, in auto mode.

Flew 3.5.0.rc4 on both a Pixhawk on a quad 666 ;and PixRacer on F450. Stab, Althold, Loiter, Poshold, Circle,RTL with landing, and an Auto mission, all just fine !
Great work as always.
Joe

1 Like

Flew 3.5.0 rc4 on 1000 g Quad Pixracer with STAB, ALTHOLD, POSHOLD just fine.

Regards Rolf

1 Like

Problems with the MB1200 XL-MaxSonar-EZ0 analog sonar and frameware 3.5.0 rc4
When I installed 3.5.0rc2 the sonar worked normally but after upgrading to 3.5.0 rc3 the sonar stopped working.
If I install a stable version (3.4.6 last version) the sonar works normally
In version 3.5.0 rc4 I got to reset all parameters the sonar returned to work but after I did the calibration of compass and initial wizard the sonar stopped working again.
I think it’s a failure on RC4
what do you think?
I USE QUADCOPTER AND FRONT SONAR

Hi Felipe,

Can you open a new topic with this problem? Please post a dataflash log in it. Since it is working after a parameter reset, it is more probably some issue in Mission Planner.

Thank you.

Edit: Please disregard the I2C related issues. Due to the lacking documentation on PH2.1 (not AP) I assumed that I could tie onto a different I2C bus, and since the Oled was working, I thought it was correct.
Thanks to a post I stumbled upon from Oxinarf - explaining that only the GPS1 I2C is being used by AP for now, I’ve fixed it.
I’ve now hacked into the GPS1 I2C wires and connected to my splitter, which has sorted out my issues.
Flow and Rangfinder are working on I2C.
I’ll leave this up for now. If you think it has no use feel free to kill it.
End Edit

Just loaded RC4 on this Pixhawk 2.1 (that I think I’ve finally sorted out - that’s a whole other ordeal)

Hexa
Pixhawk 2.1 Cube with Edison
Oled 1.3" (only works on GPS 4 I2C along with the other I2C devices)
PX4Flow - I’ll have to look through the log to see if its working…MP shows it enabled but I’m not sure.

Lightware SF11/C - doesn’t appear to be working on I2C with 3.5 RCx (2 & 3 & 4 for sure) shows a flat line in the dataflash - sonarrange shows 0 - yet no error messages. I can connect to it through the Pixhawk using lightware’s software, it see’s and shows config, can config and save params. I have this powered separately from the FC, so I’m going to see if that’s the issue although it’s never been an issue before.

Here GPS is found and configured fine

Everything seemed to load up fine.

Can’t Enable EKF3 on this PH2.1 - it slogs everything down and keeps edison, telemtry from working, and generally just makes everything slow and unstable feeling. Can’t connect and power via USB with this enabled. (At least on mine)

I calibrated accel and compasses worked fine.

Pixhawk (2 anyway) no longer makes the 2 tone sound when lose connection to radio (RC2, 3 & 4)

Alt-Hold and Pos Hold seemed to work fine.

I’ll test more when its not so windy. This was my first flight where I felt like the PH2.1 was actually working well.
Wind whipped up all the sudden right as I took off, and I had to hastily land - tipping the copter. But Crash check worked.

Figured I’d post just to get it out there.

00000043.BIN

ok

http://discuss.ardupilot.org/t/problems-with-the-mb1200-xl-maxsonar-ez0-analog-sonar-and-frameware-3-5-0-rc4/16363

I update the topic now, please go there.

Super simple mode is out of function.

@mfbs17 Do you mean super simple isn’t working?

Has anyone else tested it?

On the bench saying simple mode eventhough Ch.8 is super simple mode.some kinds of mixed up.

Hello
I have it on a switch and it works
But I don’t know what massage on telemetry was. Please remember it only works if distance between copter and start is more than? Some Meter

In my case I have both on slider på taranis and get the massage simple mode.

@mfbs17 So you are looking at a message in the Taranis, is that correct? And you are using the new FrSky telemetry mode, right? If that’s all true, then I guess it is normal to see only Simple mode in the Taranis, since the same information is sent whether you have simple or super simple mode activated - I don’t have access to the telemetry script you are using though, so no way to confirm.

@all: Please don’t do reports based on what you see on a Taranis telemetry screen. The script you are running can output whatever message it wants and isn’t helpful to us in trying to diagnose an issue.

I am using craft&theory sensor and on 3.5.rc2 I didn’t have that issue.For a second or two I see the massage super simple mod and than all of sudden changes to simple mode .Is it normal?

Is the link in the OP not working for everyone?

@mfbs17 You’ll need to ask C&T, I don’t know what their script do. My guess is it is displaying the MAVLink message saying Super simple mode enabled (which is it only shows for a few seconds) and then it is showing the flag ArduPilot sends with Super/Simple mode on.

@Crashtested Thanks, link corrected.