Copter 3.4+ update, Transmitter calibration issues

I am facing a weird issue while upgrading my pixhawk firmware to v3.3.3 to v3.4.4, in Radio Calibration, there are no green bars showing to calibrate my transmitter sticks, even after many tries,like re-installation, receiver change.

And, also the copter is not responding to any previous transmitter calibrated commands from transmitter like arming, channel change/switching.

I have searched on google but did not find any solution, if anyone solved this issue please do share here.

Thanks and Regards

Sounds like the receiver is not working. Did you check that the receiver is on and receiving input from the radio?


Yes, the same receiver is working with pixhawk firmware version 3.3.3 and all lower versions.

Yes, the same receiver is working with pixhawk firmware version 3.3.3 and all lower versions

I’m at a lose here. What type of hardware are you using for the receiver?

Since you can’t arm it that would indicate no signal is being interpreted at the input and this would be a hardware issue. Like your hardware may no longer be supported.


Hey Mike,

I am using Futaba t14sg transmitter and Futaba R7008SB receiver, and I didn’t find anything on google regarding support of these hardware with Copter v3.4.4.

Are these compatible or not with copter v3.4.4?

Thank and Regards

Hi. I had the same problem. As Markus Müller suggested in my post, I changed to 14 channel mode (I was using 12) and it works now.

Thanks @re4mat0r,

Issue solved but not from 14 channels but by using SBUS connection instead of SBUS2, since SBUS2 is depreciated and will not be supported by any update of PX4 stack and Arducopter stack.

Thanks anyway.