Copter-3.4-rc5 available for beta testing

Hi, I can confirm this. Board boots up, reports no error so far. Haven’t fly it yet, will take some time to assemble the copter around it…
Huge thank you!

Hi tabascoz, when you change the version of firmware you remake the calibration ?

2 posts were split to a new topic: Copter 3.4-rc5 test and logs

No, only once in rc2

Now i have 3.3.3, do you think that is necessary to recalibrate all ?

Flew rc5 today on a stock Iris+ & 3DR-Y6. Everything was great. Takeoff and landings in Stabilize and PosHold. Brake, RTL & Estop all working as expected.

Tested Tower Beta:

  • arm and takeoff from App
  • Dronie
  • multiple follow-me modes (no altitude issues)
  • manual flight path capture and replay as auto mission

Tested QGroundControl on Andriod connected via 3DR radio:

  • arm & takeoff from App
  • guided “fly to” points on tablet

I really like the pre-arm messaging and layout now in QGC along with the configuration section, but that’s probably a post for a different section.

I’m not sure if it is mandatory , but it is not a bad idea. I usually take advantage of upgrading major releases to recalibrate everything.

1 Like

A post was merged into an existing topic: Copter 3.4-rc5 test and logs

Fast IMU logging does not work anymore in 3.4. I found it to be very useful, especially when dealing with vibration in Gas/Nitro heli. Fast IMU logging enables us to do a frequency analysis of the IMU to figure out if the excess vibration is due to main rotor or something else. On inspection of the code I see that the routine “Copter::full_rate_logging_loop” has been removed. I was wondering why it is so. Can we please bring this back? Is there a reason why this was removed?

Not sure why it was removed, but here’s the commit where it was removed:

It was part of a bigger change to support having EKF2 do logging for proper replay. You can enable fast IMU logging by enabling LOG_REPLAY (and with EK2_LOG_MASK you can control which IMU is logged).

Hi Randy,

Spektrum Satellite support appears broken for PixRacer. I have tried 2 PixRacers and 3 Satellites. When pre-bound, I see serial signals from the receiver with a logic analyzer but no channels are detected in Mission Planner. Binding does not appear to work either. I monitor the VCC and the signal lines. There is no sign of the needed switch off on VCC and nothing ever happens on the signal line either. Same results on Plane.


Hi @pkocmoud,
Im using a spektrum satellite rx, works well, except the binding. For that i use an arduino.
But… it does not work with my clone pixracer.
I dont know the reason. :frowning:
Br, m.

I should have noted, I only have DSMx Satellites to test with.

So further testing. Using a 3DR PixHawk loaded with 3.4 RC5 the same pre-bound satellite receiver works fine.

Just upgraded from AC3.3.3 to 3.4-RC5.
Original 3DR Pixhawk.

I am experiencing constant heavy drifting in Loiter which wasn’t the case with 3.3.3.
At zero wind, my copter was moving constantly around by 3-5 meters. GPS was always good (19-20 sats, 0.5 HDOP)

All other flight modes tested (PosHold, Drift, Stabilize, AltHold, Land) are fine.

Use with Tower 4.0-beta5 with 3DR 433 MHz telemetry:
could only connect and arm once. After takeoff, I could not send any further commands from Tower until I restart the Tower app. Simply nothing happens, no errors or whatsoever.
However the data downlink and display works fine all the time.
Anyone experienced the same with the latest Tower beta?

PixRacer compass

I updated a 250 quad racer from APM micro to Hobbyking PixRacer with external Micro HKPilot GPS And Compass u-Blox NEO-6 and HMC5883.
To have wifi module workable I updated from 3.3.3 to 3.4 RC4 and now RC5.MP 1.3.40/41

The copter flies great with default PIDs, no wobbling on high speed (Flight modes: stabilized, loiter, alt hold, pos hold). There is only one issue: when I activate more than one compass it is necessary to calibrate compasses nearly before every flight.
Post Idea for reducing frustration with compass prearm failures confirms this problem.

One of 8 testflights was interupted by an EKF2 error and failsafe land with only the external compass activated.

Is there a way to solve this?

Several IMU calibrations eased up the drifting. And a reinstall fixed Tower.

Now I have the problem that I cannot arm the copter with my Tx anymore, only with Tower.

Throttle/yaw stick down/right doesn’t do anything anymore. Also Disarm with throttle down/left is after the calibration disfunctional. That worked fine before calibration. There are no error messages.
Anyone have an idea?

Besides that, I successfully tested:

  • LidarLite (PWM)
  • Precision Landing with IR Lock

I think size of aircraft motors props all up weight etc, is important to mention otherwise good or bad has little value…
Aircraft is:

  • Very small quad (550mm {21.65 inches} ) motor to motor.
  • Total weight including graphene batteries 4S 8A: 2.7 kg
  • 18 x 5.5 Quanum CF props
  • Turnigy dlux 80A ESC driven at 400Hz (not 490 which is the default I think)
  • Turnigy Multistar 4830-480Kv 22 Pole motors.
  • Separate 2S5A battery and linear 5V regulator for FrSky Rx, Pixhawk, GPS and external compass.
  • Pixhawk.
  • Telemetry to and from laptop link is RFDESIGN 900+ driven at -30 dBm.
  • Telemetry for batteries (cell by cell measurement) not total value which has no meaning: Quanum 2.4GHz

Perfectly executed tests of V3.4 rc-5 / Mission Planner were:

  • Take off in stabilise then land.
  • Take off in altitude hold, move a bit around then switch to Loiter hit Land button on Tx: Perfect.
  • Take off in Loiter, move around a bit, activate RTL switch on Tx: Perfect return, landing detection, switch off motors after programmed time.
  • Take off in Loiter move a bit then from laptop click right mouse and “fly here”. Perfect guided mode successful iterations executed in 30 km/h gust wind! Great. Hit the RTL switch, and again perfect return and landing. (No more altitude problem. Return at current altitude (+ 1 metre as programmed in the setup).

Still to be done:

  • follow me
  • Switch to RTL after follows me stop above laptop GPS. (To check that the altitude bug of 3.3 has disappeared. (Was taking absolute altitude and add to current altitude prior returning).

So great improvements all over. Thank you to the DEV guys for a great software!

Sorry I didn’t see your message. In the future it’s probably better to create a new topic rather than to reply here.

It’s most likely that the radio calibration needs to be done again. I imagine what’s happening is the transmitter is not sending exactly a zero throttle when the throttle stick is at the bottom.