Servers by jDrones

Copter-3.4-rc4 available for beta testing

Following quickly on the heels of -rc3, -rc4 has now been released for beta testing. As per usual, the latest Release Notes can be seen here..

Changes from 3.4.0-rc3

  1. Intel Aero flight controller support
  2. Bug fixes, minor improvements:
  • resolve unlikely endless-climb in AltHold, Loiter by ensuring Z-axis accelerometer IMAX can always overpower hover throttle
  • fix auto build issue that could lead to parameter corruption
  • fix EKF2 gyro estimation error when switching between IMUs
  • sanity check MOT_THST_MIX_MIN, MAX parameters
  • increase likelihood that parachute will release by reducing counter instead of resetting counter if vehicle becomes temporarily upright

We’ve still got at least two items to resolve before we can do the official release.

Thanks again to all our beta testers!

Note: if using the latest Mission Planner you may see “Bad Logging” displayed on the HUD before you arm the vehicle (the message should go away 30 seconds after you arm). This is not a problem and will be resolved in the next MP beta.

1 Like

How do fast autotune? 10 mins for roll, then 10 mins for pitch, then 2 mins for yaw and low voltage crash =(

Do them one axis at a time? Or do roll/pitch and yaw then the last one that wasn’t roll/pitch.

Yes, I agree with Big Tulsa. The AUTOTUNE_AXIS parameter is the one to set. Also subsequent tunes might be faster if the gains have been set to values closer to the ideal values. wiki is here in case it helps: http://ardupilot.org/copter/docs/autotune.html

Will there be fix for clone pixracers? PX4 firmware added a software fix in 1.4.1 release.

Randy,

Thank you and all devs for this release!

The yaw bug is gone ( for me it was the most critical ) , tested loiter, poshold, rth and brake, everything went very fine with it. There were some progress with oneshot however I believe there is still some work to be done.

I’ve run autotune with rc2 release. Is it necessary ( or recommended ) to run it again?

Fernando,
There was one minor improvement to autotune in -rc3 but it only matters for quite powerful copters (i.e. ones that have a very low hover throttle). So if you’ve got one of those you might want to try again especially if you’re unhappy with your current tune. If you feel like your copter is flying fine though, I don’t think it’s necessary to do another autotune.

@Teci, can you please test this firmware:
http://uav.tridgell.net/Teci/arducopter-quad.px4
it adds a sensor reset on FMUv4 (the pixracer) on startup to try to work around the sensor brownout issue on some boards. If you can test this and confirm it works then I will add it to master.
The PR is here: https://github.com/ArduPilot/ardupilot/pull/4800
Cheers, Tridge

Thanks Tridge;

I loaded the firmware you sent and bench tested with mission planner. All sensors are working as it should. HUD shows correct positions, accel and compass calibrates succesfully. Looks like it’s working. I can flite test it tomorrow. I’m not familiar with NSH, If you can tell me what commands I need to type I can test sensors from there too.

The test you’ve already done is sufficient, thanks!

1 Like

Hi,
I’ve just got a crash with 3.4-rc4. Was my fault, I was testing too many things at once, because i had a hacked sonar attached over I2C. Although im not really sure if that affected the flight or not, but it was scary.
Started in alt hold mode to check how the sonar behaves over concrete surface.
Moved the throttle to above middle, after a sec it started climbing rapidly. I switched to stab asap, and tried to land but the copter lost its control and hit ground from 1.5 meters.
My auto analysis crashes, and i didn’t find the cause. (nor i find any sonar data logged.)
two props and one bumper minus :slight_smile:

2016-09-09 19-01-33.tlog (116.6 KB)

Cheers :slight_smile:

For me, something is seriously wrong with 3.4-rc4 on a PixRacer. With the same config, rc3 was great.
I get weird movements, pitch offset slowly changing. After landing, OSD horizont not leveled. (had the same with the crash mentioned, but recalibrated accel and compass)
Where can I get rc3 without building it? Do you have any idea whats going on?
2016-09-10 14-46-12.zip (498.5 KB)

Marcell,

Do you have the .bin log regarding the crashed flight? How was your rangefinder parameters? I had a similar problem with 3.4rcs and sonar. My altitude controller was really bumpy. I find out that the reason was wrong readings of my sonar. I solved the issue by repositioning the sonar.

Marcell,

Thanks for the testing and feedback including the dataflash log.

So it definitely looks like we’ve got some attitude estimation errors in there. See the graph which shows the difference between the older DCM vs newer EKF2. There’s at least 20 degrees of difference which is a sign that something’s gone wrong.

It looks like some of the arming checks are turned off. Maybe Baro, GPS, INS and parameter/sonar are off? In particular turning off the INS check is an unusual thing to do. Without this check the accelerometers and/or gyros could be inconsistent (i.e. producing bad values).

I think it would be best to turn those arming checks back on and then address any underlying issues that come up. I know the compass consistency check is upsetting some users (especially pixracer users) so we’ve got a fix coming for that which will relax the check a bit. The compass is unrelated to the INS pre-arm check though.

Hi,
Thanks for the analysis. As far as I remember, I had to restart the copter once, because I was getting bad AHRS, and sad-beep-warning preventing arming. I think i have not disabled any of the checks (although i will check at home later today), therefore i think i just got the right moment to arm, before the problem showed up.
I replaced my gps/compass recently, but i flied that without problems on rc3. One thing i havent re-calibrate was the motor-compass calibration. Just forgot about that… Can that cause this problem maybe? My vibration levels are not that high i hope.

Is there any specific test to recheck this, or i just need to fly some more?

When i did Autotune with RC3 on my big Y6(820mm)5kg…pitch and yaw worked without problem…but for roll it just did not started until i touch sticks…than it do one step and again nothing until i touch sticks again…i manage to complete autotune this way…i dont have time now,but i will make proper post with data log latter…

Emin, that sounds like the stick are not fully centered so during autotune it thinks that the pilot wants to control the vehicle.
Thanks for testing!

Marcell,
If you’ve got an external compass, I think you can just turn off the motor-compass calibration.
I wouldn’t expect the motor-compass calibration to cause this problem.
I think the best thing is upgrade to -rc5, turn on all the arming checks and fly again. If any errors are reported while arming, let’s address them.
Also of course, make sure you’re not moving the vehicle while the main LED is flashing red-blue soon after startup. I imagine you’re careful about this already but just in case.

I’m going to close this thread because -rc5 is out.
http://discuss.ardupilot.org/t/copter-3-4-rc5-available-for-beta-testing

Servers by jDrones