Copter 3.4.3 Servo Drop Ball


Would you have any detailed tutorial on how to connect and control an analog servo with Pixhawk? This is my second day trying to make this work following the documentation, no luck. I’m using Copter 3.4.3 and Mission Planner 1.3.43. My goal is to simulate the new Gripper feature from Copter 3.5 that allows us to deliver things.

One question is, do we have to Arm the vehicle to make the servo work? There is a video from Randy where he is dropping a tennis ball using the camera trigger. And there is also a newer video where he is demonstrating the Gripper feature. I am interested in the first one using the camera trigger for now.

Here is my setup so far:
Servo signal wire is connected to AUX OUT #2 (RC10).
Servo power and ground wires are connected directly to a 5v BEC.

CAM_TRIGG_TYPE = 0 (Servo)
CH7_OPT = 9 (Camera Trigger)
RC10_FUNCTION = 10 (Camera Trigger)
RC10_MAX = 1900
RC10_MIN = 1100

On Camera Gimbal Screen, Shutter:
Pushed = 2000
Not Pushed = 1000
Duration = 10

With this configuration I believe we would be able to make the Servo move when the CH7 is switched, since it is configured to trigger the camera. But even with the vehicle armed, it seems that there is no Servo signal at all. When I right click the map and select “Trigger Camera Now” nothing happens. So there is something I’m missing here.

Any of you knows how Randy configured his Copter to drop that ball?
I appreciate your help!
Kind regards,



This is the type of post when you find the solution just after asking for help. My apologies, I should have tried this before. The Servo is moving now! It sees that if you connect the signal wire only, it won’t work. Once all wires were connected (ground, power, signal) to the Flight Controller it started to work.

So it looks like we must connect all Servo wires and all BEC (ground, power) wires to the Fligh Controller. Please, let me know if this assumption is correct. If it is, I would suggest an update to the documentation saying that the BEC must be connected to the AUX rail along with the Servo connector. But, why it does not work when it has only the signal wire connected to the FC?

Anyway, thanks in advance for any comments from then on.


Great that you got it working. I had a peek at the wiki page describing the servo set-up and it appears to show that the BEC needs to be connected to the rear rail. You’re saying that on your board, it’s not enough that it’s connected to the servo rail but that it actually needs to be connected to the AUX side of the servo rail?

What board are you using by the way?

Hi Randy,

I did the test connecting the BEC to the MAIN out pins and it works too. So as long as you have the BEC connected to the board, and the Servo connected to AUX, it will work. My board is the HKPilot32.

The picture in the documentation depicts the BEC connected to the Flight Controller. But, since there is no wording saying it is mandatory, firstly I tried to connect the Servo power and ground wires to the BEC directly, and left just the signal wire connected to the FC. That’s why I got confused :slight_smile:

Hope this post helps other people trying to solve the same problem.
Thanks for your amazing job!