Continuous stalling during auto mission

have been using my e-flite Opterra with a APM 2.8 flight controller for some time now and have succeeded in completing auto-missions as far as 25km (out and back). Yesterday, I have encountered a weird situation that I have no explanation for - see KMZ-file or the APM log.
This video from my onboard camera shows the movements of the plane: Video 1.
After ~10 min of smooth and uneventful flight (calm weather, almost no wind), I notice oscillations around both axes - but nothing critical so far.
This movement seems to recede on its own, until at 15:35 (see video timestamp), things start to become critical. The horizon begins to tilt and drop as if the bird was tail heavy or severely underpowered all of a sudden. The plane stalls a couple of times and the flight controller recovers each time - but height decreases constantly and the “help, I am underpowered” feel remains. This Goolgle Earth screen shows the flight path. (The white line is the planned path.)

At 15:41, the final stall ends this misery - the plane crashes on a meadow and is a complete loss.

You might want to look at the last few seconds of it’s life in slo-mo

I have no idea what caused this situation. Battery and everything else could not move inside the plane; I am certain that the CG didn’t change. The APM log shows a couple of significant changes at about 15:35 - especially regarding throttle output:

Unfortunately, I am not sure what this means. Could it be that the APM detected speed loss and gave maximum throttle - with no effect? This could explain the flight path - no motor support and the autopilot tried to maintain height by simply pulling up…?

This would mean a certain stall. But after I collected the pieces, the ESC worked fine. And the APM log shows normal power consumption during the the critical phase:

In the end I have no idea what happened. I am sure the answer is somewhere in the log - but I am unable to find it. Is somebody out there with an idea? Any hint would be helpful. Thanks.

1 Like

One potential cause is the prop coming loose. Was it still attached when you recovered the pieces?

Yes, the prop was still in one piece and attached to the motor.
Only the motor was not attached to the fuselage anymore… :frowning:

No, seriously. The idea that there was simply no thrust available matches the flight path. But how does APM work: would the autopilot simply pull up to try matching the programmed flight path and thereby forcing one stall after another?

That depends on parameters and setup, but in your case, yes. There is no feedback on the motor, and no airspeed sensor. ArduPlane will simply try to achieve the desired altitude and airspeed by using both throttle and pitch. You can see this in your log, including when I think you completely lost propulsion (ch3 goes to max and stays there, pitch oscillates around a bit). The TECS controller can be a bit more scientific about weighting speed vs height, but you need an airspeed sensor for that to work (you had airspeed_enable = 0, so the TECS_SPDWEIGHT parameter doesn’t do anything).

James, thanks for the preliminary analysis. You are right, it looks as though the autopilot gave full throttle, but the plane didn’t pick up thrust accordingly. The propeller was not the problem - it was still attached after the crash. That would leave the ESC and the motor itself. But if that was the case: How come the power consumption shows a pretty normal pattern? If there was nothing drawing juice from the battery (ESC or motor), I would expect the log to show a significant decrease in power consumption, (I assume I can use power consumption at least as an indirect feedback that the ESC/motor was still active.) Would it help if I made the parameters file available?

Experts out there - what do you think of this:

Around line 20k, there is a drop in current drawn from the battery (green). At the same time, the speed begins dropping (blue) and the throttle output rises until it maxes out (red).
What can this mean? Well, probably that James’ analysis is correct.
Obviously, the whole power train stops working, meaning the motor doesn’t run and draw current.
The autopilot tries to compensate and increases throttle output. As this doesn’t help, it begins pulling up to match the programmed flight path until the speed drops to almost stall speed and the deadly dance begins.

The only fact that doesn’t jibe whith this scenario is that I can’t find anything wrong with the motor, ESC or prop. No loose connection or anything.
However, at this time my best guess is that maybe heat or vibrations made the ESC quit working in mid-air.

Any ideas?

I am installing APM 2.8 in an Opterra and I would greatly appreciate it if you could share some settings, especially regarding the following parameters:
TECS_LAND_ARSPD (barometer or speed sensor?)

Additionally, if you happen to know what the Opterra’s stall speed is, I’d greatly appreciate it.

Hi Tony
The parameters you ask are all about autonomous landing the plane if I am
not mistaken. I have never tried that. I guess I just cannot bring myself
to trust the APM to handle takeoff or landing my plane for me.
As for stall speed, for my configuration this would be at 27km/h or 7.5m/s.
Good luck!

Tony Gil schrieb am Do. 21. Dez. 2017 um 12:04:

Hi Arnd,
would share your APM setting file?
Very appreciated :grinning:
Have a nice day!

Hi Steffen,

do you mean the doomed settings that were active during the crash last year? Or do you mean the current settings?

By the way, I’m still flying the Opterra, but have changed to a 960KV motor and 4S.
I have now more power available and the plane handles additional weight very gracefully. With all the cameras and FPV stuff plus the massive 10.000mAh 4S battery, I have more than 2600g of weight.
Works beautifully, though:

I would prefer the good working ones if you don’t mind :wink:
The “pimped” setup sounds good!

Here is my current parameter file:20180928-opterra.param (5.8 KB)

Dankeschön :smiley: