Connects kind of but not really, DroidPlanner 2.8.1 RC1

Hi there…

I have an older Nexus 7 and some 3DR telemetry radios. The radios work with Mission Planner on a pc and Andropilot on the same tablet however when I connect to my Pixhawk (AC3.2) I get connected and it represents the flight modes, but no other data seems to stream across. No position or attitude data. Because of this, I can’t use the tablet as a GCS.

Any thoughts on what I can check? I verified the baud rate is 57600 like it is supposed to be but don’t know what else to look for.

Thanks in advance,

Go to DP setting and set what you want it to report. (Bat.V, Alt, and ect.)
You can also set it to show HDop and sat count.

Hi wcp1947,

By going to settings, advanced, the only setting I can find is to display HDOP. Nothing else you mention is even visible as an option. Is there another RC I should try, perhaps? I’m on the mailing list for release candidates but don’t believe I’ve seen one after 2.8.1 RC1 was released…

So, I had a look at my SR* params on the pixhawk and something zerod them all out. I got them back to defaults and am now getting attitude and position data (as well as what mode I am in) but I cannot do the following:
[]Load a mission
]Write a mission
[]Find any mention of Follow Me anywhere (on my friend’s older version there is a setting to enable Follow Me mode - I do not have that option)
]Arm (I can disarm, though)
[]Download parameters
]Change Flight Mode

I AM able do to the following:
[]Receive audible feedback on mode changes, arm status, battery levels (even though that option is disabled in settings)
]Receive Position and Attitude data
[]View satellite count, HDOP

I am not sure if I can do sensor calibration, and have no desire to try at this time.

In DP2, the Telemetry Link Speed is 57600 (Default), and here are all the stream rates (again, nothing modified, all from default) :
Waypoints,GPS raw, fence data, current waypoint, etc: 2
Attitude: 10
VFR_Hud data: 2
AHRS, Hardware Status, Wind: 2
Position data: 3
RC Override: 50
RC Channel Data: 5
Raw Sensors: 2
Raw Controller: 3

All the while, the radio link in DP2 is showing 100% signal strength, with RSSI at -45, RemRSSI at -45, Noise at -96, RemNoise at -100 (I’m indoors at the moment), Fade at 48-52, and RemFade at 54.

Finally, just a reminder, I can connect to and fully manage the aircraft from Mission Planner using the same radio (in fact it was that radio where I saw the SR* params were wrong and corrected them)

Hoping you’re able help, this is pretty confusing. Thanks in advance!


  1. You will not see Follow Me until you are flying then you can pull up menu for the FM options
    from bottom right
  2. on the left side pull down menu you should see edit that is where you make you mission
    then I think back on right side you can pull down menu to wright mission (at work now will check when I get home) to APM.
  3. more Info here … 6585781402

I will check out and get back


I hope you don’t mind re-reading my note again. I am not saying I don’t know how to do these things (such as read/write missions) I am saying the functionality does not work!! For whatever reason, the items in my list above that are under the “Does Not Work” list are not being processed properly by either DP2 or the AutoPilot.

Also, When flying, (or on the ground) there is no option to engage Follow Me, anywhere. I’ve seen screen shots from other people using DP2 and they have a button for follow - I do not have that button.

Are you sure we’re talking about the same product?

I appreciate you trying to help, but, I am not sure you’re reading my replies fully, as these things are spelled out clearly when I describe the problem. I click these options (such as read or write mission) and nothing happens which is why I am asking for help in troubleshooting the problem, not learning how to use the tool.

Thanks for the link to the google community, I’ll have a look through there as well to see if there is anything helpful to this issue.