Connection Lost: 3DR/Telem Radio

Hey guys,

I am pulling m hair out over this issue I’ve been having. Now, I have a Mac and I’m using QGroundControl to connect to my Pixhawk/PX4 autopilot. I’m running latest ArduPlane (but issue repeats with ArduCopter etc).

So when I plug in my cheap 3DR radio, it will connect and start to transmit data to the GCS from the plane. About 65% of the way through this transmission/connection the connection is lost (as per screenshots. After this, I cannot connect in any form. If I try to manually connect I get the following error: “resource busy” indicating that a connection is existent. Indeed, the TELEM radios show both solid green lights meaning they are still communicating with each other.

I have installed relevant CP2012 and FTDI drivers to connect the device. It was running fine! I had stable connections to my MacBook and iMac. Now, both devices will not connect for more than 20 seconds. I’ve run the autopilot in a minimum configuration, with only the radio and a stable USB power supply. I’ve flashed the firmware again also, but still no cigar. I’ve done a clean install of Mojave, was on High Sierra before, and reinstalled both APM Planner and QGroundControl but still no connection (or at least, lost connection 20 seconds after first connect). Also tried the daily build of both AMP and QGC.

Any ideas??? You guys are my only hope!

Try powering the FC from a battery instead of a USB cable.
I vaguely remember an issue in the past powering with USB while trying to use the Telemarking port.

Hmm… I tried with the batteries too, this is when I first noticed the problem and hence swapped out to USB thinking it would be better?

My power setup is as follows: 2x 5200 mAh 11.1 V 3S cell wired in series. Power is loaded through a PDB capable up to 140 A, distributed to two ESCs, and a common power module. The common power module powers the PX4, along with servo rail power from the two ESCs, both at 5.4 V.

I should mention, this issue still occurs in minimum configuration - i.e. with both ESCs disconnected, and all other components. The only connected component is the 3DR radio with battery power.

One of my worries is the common power module is reading nearly 24 V, because of course the batteries are in series. I think it’s designed for 18 V - but this wasn’t an issue before and I managed to have the radio stably connected with 24 V loaded.


No issues reported when flashing and running PX4 Autopilot Pro instead of ArduPilot. Connection is stable, on battery, and also on USB. Telemetry radio will connect to FC and will send commands.

This confirms that hardware connected, all Mac/FC/Power Systems are NOT causing the issue. This is an ArduPilot issue.

The only thing I haven’t tried yet is updating the firmware (if applicable) on the Telem radios. The only reason I haven’t done this is because I don’t have a USB to JST cable. I believe it’s more than just a cable and requires a modem/convertor no? I tried wiring a USB to JST (or, accurately, DF-13 4 pin) cable but it would not connect so I’m sure something sophisticated is required.

I have had this long ago with the Mac.
I was pondering your question and did recall that there was some driver issue that was giving me erratic radio connections.
I cannot recall the exact issues but it was buried in the site where I got the CP2012 and FTDI drivers.
Sorry I can’t be more specific.

You’re right I went through the FTDI and CP2012 drivers extensively, from the VCP and Silicon Industries webpages respectively. I ran some system_profiler commands on my Mac and confirmed they’re working properly by running some other FTDI boards connected to my Mac. These all worked fine.

Then, I actually found a work around… I’m not sure why this is the case but changing SERIAL1_TELEMETRY to MAVLink2 rather than MAVLink1 fixed the issue. If I change SERIAL2_TELEMETRY to MAVLink2 as well, then the issue reoccurs. So it appears to be some problem with having a single protocol assigned to both ports? Weird because I never had an issue with that before?