Connecting the Iris to the tablet

I cannot get the tablet to see the IRIS in DroidPlanner 2. Am I missing a step?

Yes. You missed the step of describing your setup and what you actually did or tried and what happened (error messages, etc.).

I have a nexus 7 9 in. Droid tablet. I have the 3DR Radio With micro-USB and Android OTG ground station adapter connected to the tablet. I loaded Droid Planner 2. I hit connect like in the video with the IRIS and remote on. It give me the error message MAVlink error. No device connected.

Is there a dip switch that I need to hit on the controller or is a setting in the IRIS or tablet/Droid Planner 2?

Any help would be great!!

I have the same tablet. sometimes I have to unplug the otg cable and plug it back in to connect. But actually don’t plug the the otg cable in till after you open the droid planner app. This always works for me
You should get a message that says “open droidplanner when this USB device is connected”?
hope this helps

Make sure the blue plug is on the tablet side.
Even though the cable has the same plugs on both side, they are not interchangeable.

I tried waiting to plug it in and the blue is on the tablet side. Any settings that I need to put in? Does the radio need to be on or does IRIS need to be armed. It works just fine with the usb to my laptop.

Here is the tablet that I have.

Pyle Astro PTBL92BC Android 9-Inch Bluetooth Digital Touch-Screen 3D Graphics Wi-Fi Tablet … 1_ST1_dp_1

•Google Android 4.0 Operating System
•1.2GHz Cortex A13 Processor Chip with 3D Graphic Acceleration
•File Compatibility: MP3, MP4, WMA, WAV, AVI, WMV, MOV, JPG, JPEG and much more
•High-Speed Wireless Network: 802.11 b/g/n Built-in Bluetooth Technology for Wireless Data Streaming
•Includes AC Adaptor, USB Cable and OTG (Micro USB Adaptor) Cable

I got it to work 1st time on my cell phone (Galaxy S4) :smiley: . No problems. Maybe it is the tablet :question: What brand of tablet are you guys using :question:

You can start with this list: … le-Devices

But unless you want to use a separate Bluetooth solution, don’t get the Samsung Galaxy Tab 3.

It looks like the Nexus 7 is the safe bet. I think I’m going to see what kind of price I can find on last year’s model.


I am having the same problem.

I have the blue end of the OTG cable in the tablet. (Nexus 7)
I have the 3DR radio on the other end. The LED now lights in the radio with the cable the correct way.

Power is on to the X8.
I try to connect in Droidplanner2, and I get a connecting… MAVLink Error: no devices found

When I try to connect in Droidplanner, I get an audible “disconnected”

I recently turned on bluetooth, but no help. I thought that with a cable connection, bluetooth is not required.
Is the cable for power only, or for power and data?

what else should I try?

after another shut down and power up of the tablet, the prompt appeared asking what app to use with the USB device.
I pointed to Droidplanner 2 and it connected this time!
Hope it continues to connect…

APM 2.6 3.2rc7 450 frame 3D radio using Nexus 7 (4.3 and 4.4.4 both work)

I had the same problem and found out I had to:
#1 Power up 3D radio on Quad
#2 Power up Nexus
#3 with droid Planner installed but not open
#4 Plug in 3d radio (to Nexus) as soon as I plug into Nexus
it ask what program to use. then I start DP
#5 then push connect on Nexus.
I don’t know if that will help but thats what worked for me

Thanks wcp1947

That seems to be the order that it worked once for me. I will make that my routine!