Connecting Mission Planner with SITL on VMware/Virtual Machine

Hi Everyone

I am unable to connect to connect on mission planner on my VMware virtual machine. Followed the same steps as here

https://ardupilot.org/dev/docs/setting-up-sitl-on-windows.html

tried to configure through IPs visible on the system but nothing worked. If there is another method to do it ??

Thanks and Regards
:heart:

Can you ping your host machine IP address from the VM Guest OS ?
Did you switch off Firewall in VM guest OS and in Host OS ?

What do you want to connect to in your Host OS ?

@Eosbandi

Hi I am actually trying to connect SITL to the mission planner on my virtual machine and for some reason it ends on getting parameter forcing me to update firmware to 4.1.2 and then crashes.

I changed my VM network type to bridge now instead of NAT and in both the cases it doesnt work hence I assumed it might be with the ip configuration as there is an additional step if you use VM you got to configure IP of the host machine as described in the link.

I can see SITL working but not the mission planner it crashes!

I am not able to run gazebo on windows hence was setting up everything on linux.

I am not even sure whats the problem cant connect from simulation window either

thats the last think I can think of that could go wrong!

SO again.
What is your HostOS ? Is it a Windows, a Linux os Ubuntu
Your runs an VmWare under your HostOS ?
You tries to run Mission Planner under Ubuntu and connects to a SITL instance also compiled and run under Ubuntu ? Are you SU ?
Or you runs Mission Planner under your HostOS and tries to connect to SITL in Ubuntu ?

(built in SITL in Mission Planner works only on Windows)

If your Host is Windows then why the VMWare ? You can use WSL which is much more integrated and easier to use than a VMWare.

@Eosbandi am using windows as my host operating system
My VMware is hosting linux Ubuntu 18.04 on the windows machine
I am trying to run everything on Ubuntu linux
I was trying to run mission planner solo but then it still cant connect as it has an error as seen below

I could read this error for windows they need to fix the arduino driver and I am not sure for the windows
hence I tried to connect it through SITL instance and it didnt work either.

I will look for WSL so far I have been following ardupilot page I have had used mission planner with cygwin terminal before though!