Connecting Mission Planner to SITL on Linux Machine

I am trying to connect Mission Planner running on a Win10 laptop to SITL on another laptop running Debian 10. I have everything working fine when I connect SITL to QGroundControl on the Win10 laptop. But when I attempt to connect to SITL with Mission Planner instead of QGC, I get stuck at “MAVLink Connecting” pop-up. I can then kill MP and QGC can be started and connected no problem.

I can start SITL either with the parameter in the command or enter “output add” into MAVProxy.

In MP, I pick the UDP protocol, click on Connect, ensure the Port is 14550. I’ve also tried Port 14551. Both work in QGC but not MP.

Both laptops are connected via ethernet cables to a switch which is connected to a router. Both machines have static IP’s assigned by the router. Wireshark on the Win10 machine shows UDP traffic flow between the two machine for QGC. For MP, there is only traffic from the SITL laptop, never any return traffic from MP to SITL.

Does anyone have an idea how I can get MP working with SITL for my setup?


You may need to try the UDPCI option in MP and enter in the IP of the machine that MP is running on.

I’ve tried that option as well and have not been able to get a connection.

I also uninstall the program and deleted the \Documents\Mission Planner directory. Then downloaded a current copy of the program and reinstalled MP. Still no change in the result.

So, has anyone tried and successfully run MP on one computer and connected to SITL running on another computer?

Made a quick check, it works flawlessly.
I added the IP address of the GCS to Mavproxy with the output add address:14550 command, after that MP was able to connect from that machine via simple udp.
(Mp version used is 1.70)

Thanks for the sanity check. I’ll have to dig into the firewall or security settings to see what is blocking the traffic. Must be something specific to how MP is set up on the Win10 laptop. Illustrates one of the reasons I don’t use Windows if I can avoid it. Just can’t in this situation. (Also, MP v1.70)

Just switch off firewall to do a check if everything else is OK. If it does not work without the firewall then the issue lies deeper.

Well, I solved the problem. I believe it was caused when I previously had un-installed Mission Planner and Windows left the firewall rules in place. I noticed there were two different entries for MP in the firewall list. One for public networks and one for private networks. One checked and one un-checked.

What I did was, (1) un-install MP, (2) remove the /Documents/Mission Planner directory (likely not necessary) and (3) remove the rules from the Windows Firewall for MP.

To delete the Firewall rules:
open - Settings
search for “firewall”
Pick - Firewall & network protection
Pick - Allow an app through firewall
Click - Change Settings
Look for any entry for “Mission Planner” and select
Click - Remove

Then I reinstalled MP again. I started MP in an administrator type account. During the first run of MP, a window pops-up asking to allow network traffic on public or private networks. I assumed on prior installs whatever was checked was good. This time, however, I checked both boxes.

Now I can go to a non-admin type account and start MP. I pick UDP, enter the port, click Connect and it connects to the other computer running SITL. Success!

Now on to the next step. Connecting X-Plane with SITL.

1 Like

Today, I was able connect SITL and MAVProxy on one laptop (running Debian 10) to a Windows 10 laptop running X-Plane 11 (with a Taranis X9D+ as a joystick) for it’s flight dynamics and Mission Planner or QGroundControl as my GCS. The laptops were connected over ethernet. Worked pretty slick.

I’ll document my setup in an ArduPilot Blog post soon.

1 Like

Hi Mike,

I’ll document my setup in an ArduPilot Blog post soon.

Please do so, I’d be happy to control SITL with my Taranis X9D and to date I cannot figure it out…

Regards, Patrick

It worked for me!!

Thanks for the solution.