Connecting Mission Planner to CubePilot using the FPV Radio Telemetry

I have been trying, for about a week now, to establish a connection between Mission Planner and CubePilot using the FPV Radio Telemetry Modules (Air and Ground) but I haven’t had any success yet. Both modules are connected to each other as evident by the solid green light on them when connected to the CubePilot (Air module) and Ground Station (Ground module). I tried loading settings to both modules from the Setup > Optional Hardware > Sik Radio page on Mission Planner and both modules received the same settings as expected. I have chosen the COM10 (which is the right com port to use as seen from my device manager) and a Baud rate of 57600, but when I hit the connect button, it takes about 30 secs trying to connect and then returns an error message saying “No Heartbeats Packets Received”. This is causing me a serious delay in my work. Please, how do I go about fixing this issue ASAP? I have tried so many troubleshooting steps as seen online and also gone through the online documentation.

what radio modules and what flight controller do you have? Can you post a picture of your parameters for both the air and ground units? Have you set the proper serial port on the flight controller to work with the radios where you have them hooked up. Do you have Tx->Rx and RX->TX connected on the flight controller to the radio. You say you have a connection between the radios which means that the air radio is not receiving telemetry packets from the flight controller. This is usually indicative of not having the proper serial port configured or not having the wring hooked up correctly as mentioned above.

Hello! Thank you for your response. I am using the FPV Radio Telemetry (915MHZ). Also, I am using the CubePilot Cube Orange (ArduPilot PX4 AutoPilot).

What do you mean by setting the proper serial port on the flight controller? Do I have to set anything on Mission Planner before connecting to AutoPilot? Note, without any connection established, I cannot access the Full Parameter Tree to set up anything there. The TX & RX are well connected. I just double-checked to make sure of this. Can you please reach me via for further help/troubleshooting? I will appreciate that. Thank you.

Do you think there might be a compatibility issue between the version of Mission Planner and the CubePilot or between the Radio Telemetry and CubePilot or does it have anything to do with my Laptop itself or do I actually have to set up anything on the mission planner before establishing any connection to the autopilot? It’s all confusing because I used this same Radio on the same autopilot with same wiring connections last year and it worked. The only difference now is that I am using a different laptop with a new installation of Mission Planner. I wasn’t the one who installed the Mission Planner on the other laptop last year, and so, I didn’t set up any myself last year. I just used it as is.

Plug in the flight controller via usb and select it in the com port. can you provide a picture of how you have the radio hooked to cube orange what is the name of the port you have it connected to. you need to set the correct serial port where you have the radio hooked and make sure the baud rate also matches.

1 Like