Servers by jDrones

Connecting HERE V2 to UC4H Node

(Vandan Rao) #1

Has Anyone tried connecting the Here V2 ( CAN enabled version ) to the UC4H general Purpose Node ?

Is it possible ? I tried connecting them and the node was not detected at all. are there some protocol difference ? @olliw42 Could you please help me here ?

(Evan Williams) #2

I can confirm that the Here V2 in UAVCAN mode is compatible with the UAVCAN ecosystem, if that’s what you’re pursuing.

Are you trying to hook it up via UART to the General Purpose Node?

Or are you just putting it on the CAN Bus?

Is your Here V2 brand new?
If you are using the UAVCAN feature of the Here V2, I’d just like to double check that you’ve flipped the internal switch (you have to remove the casing) and followed the firmware update instructions here:

(Vandan Rao) #3

I am hooking it up via the canbus at the end of the daisy chain of general purpose nodes.

and Yes! the Internal switch is flipped to enable CAN

Is the latest firmware for HereV2 working on UAVCAN or is it some other protocol? I have it updated to the latest.

(Evan Williams) #4

Yes, I have dual HereV2 units running via UAVCAN on one of my builds.

Some things to check:

Do you have a terminator somewhere near the end of the daisy chain? Things work without terminators (or badly placed ones) until you get a long transmission line or a lot of nodes (from my experience).

Have you manually set a Node ID on the GPS? Most versions of the ArduPilot code do not yet support Automatic Node allocation.

Double checked your GPS_TYPE parameter?

If you don’t have a Zubax Babel to check it, what kind of readout do you see when using Mission Planner with AP in SLCAN mode?