Servers by jDrones

Connecting companion computer to omnibus f4 V3 - UART not working. Need troubleshooting help

Hey
This is my first time building anything like this. I having some issues with UART not working between my omnibus F4 v3 and my raspberry pi zero w.
I made sure that the tx pins and rx pins were connected on both FC and CC. Originally set the baud rate to 921 600 (throughout my troubleshooting this changes). Set the serial protocol to mavlink 2.

Things I’ve tried:
On Pi side:
-Peter Burke’s Mavlink build - This searches multiple Buad rates (No luck on any rates)
So i thought i may have stuffed up the set on this build. So i notice that Rpanion-Server provides an
image ready build. So i thought if i used this it would rule out a pi side software issue.
-Rpanion-Server v0.6 pi zero build - No luck again.

On FC side:

  • Tried all different baud rates
  • Tried uart 1,3 and 4 to check it wasnt a serial problem -no luck

Is there anything i can do on to check that the pi’s uart is working properly? I dont have a spare FC. But i do have an old raspberry pi sitting around. Other than that let me know if i may have missed a something.

Thanks,
Uno

Edit: I bought my FC from banggood. This might be a fake board causing some issues.

hi, i have a similar issue on an f405 wing fc. telemetry port works with an esp8266 on it but i need pi toadd video.

I mixed up the tx and rx pins on the pi. This probably wont help you, but i thought I’d let you know.

i wiggled and it worked. now i have resoldered the pins and it works well.

Servers by jDrones