Connecting Bluetooth with APM

Hi, I’m trying to use Bluetooth to communicate with my APM 2.6 telemetry port.
So far changed the baud rate of my BT module to 57600, paired it successfully on my PC and Android Tablet, but can’t get it work on both MissionPlanner and DroidPlanner.
I tried to swap the TX and RX wires, but no change.
Can anyone help me how to set it up for dummies ?
I’m not sure If I have done everything correctly.

I tried to get it to work, but no results.
The Bluetooth module has a solid red and solid green light when I try to connect to APM.
I tried 2 different BT modules and 2 different APM’s, but it’s the same result. Both baud rates are 57600.
BT is paired to Android or PC and seems to have established a link, but no data transfer. I crossed the TX and RX wires with no luck.
Droidplanner 2.2.5 said always “link lost” like every 10 seconds.
Droidplanner 1.2.0 said “conected”, but no data transfer.
MissionPlanner can’t establish a link and timeout.
I have no idea what to do to solve this problem…