Connecting APM Planner to Ubuntu 14.04

I recently purchased a 3DR Aero drone and I would like to connect it to my laptop (Ubuntu 14.04 and APM Planner).

-I am a member of the “dialout group” so I can use the comm ports.
-I tried to push the “connect” button in the top right corner and get an error "Error opening port: No such file or directory"
I tried to follow the initial setup instructions and “updating the firmware”. When I get to the step where it asks me to unplug and plug back in the USB nothing happens and I just cancel out of it. By the way, since this is a factory built 3DR drone I assume I actually do not need to update the firmware? Also I am assuming I have APM:Plane 3.4 since I bought it in December. It does not say which version it is on the device.

One thing that I did not see in the instructions is if there is a driver I need to install. Is this my problem or is it somthing else?

Which device are you selecting, it should be ttyACM0 for example baud will be 115200 (this is for usb)

In the Flight Data view you can seen in the Info View -> Message tab for version of ArduPlane that is installed.

also, did you remove modemmanager ? (sudo apt-get remove modemmanager) ?

Looks like removing modemmanager did the trick. At that time the correct ports started to show and everything worked.