"Config error: failed to update IO firmware"

Hello forum,
I am working on a drone using pixhawk 2.4.8 on arduplane 4.1.7
I recently did the last mission planner update and since that day, when I connect to the pixhawk, the error message “Config error: failed to update IO firmware” is displayed
Also, I can’t do any motor test and the message “Command was declined by the autopilot” is displayed (I don’t know if it’s directly related)
Does anyone have an idea of how to proceed
I wish you a good day

Try rebooting the Pixhawk with the safety switch pressed:
https://ardupilot.org/copter/docs/common-safety-switch-pixhawk.html#using-the-safety-switch-to-force-i-o-board-firmware-update

Was it an update to Mission Planner, not ArduPlane, which caused the problem?

Hello kd0aij,
Thank you for your quick reply and sorry for my delay!
The problem was actually with our pixhawk which had a defect and it has been fixed.
Have a nice day

[quote=“Nicolas_Bohly, post:3, topic:83518”]
The problem was actually with our pixhawk which had a defect and it has been fixed.

Hi Nicolas how can I fix the defect on the pixhawk I have the problem with it too