Completely and Utterly Baffled

Hi all,

new here and doing my first Quad (Deadcat frame) and its driving me kinda crazy.

Problem is motor No. 1 … on spinup motor 1 jitters and tries to what seems like go both directions.

I know its not the motor because i plug that motor into another ESC and its perfectly fine.
I know its not the ESC because i have tested that esc on one of the other motors thats working on the Quad.

I have checked all solder connections, bullets, leads etc etc etc. Only thing i can think of is the software. From day #1 after installing (multiple times) mission planner when selecting the type of quad on the right hand side is a pulldown that should populate itself with selections and that NEVER loads any options.

Also when going into terminal in mission planner to do motor tests when i click connect its just a bunch of garble scrolling downwards forever and ever until even the program freezes and i have to end task it.
so i am not sure if its even loading the correct quad firmware.

But AGAIN! i have moved motor 3 signal wire over to motor 1 (thinking maybe output 1 its trying to act as a servo) but motor 3 spins up fine so i doubt its firmware as well.

After years of debating which flight controller to get (my mini quads all run CC3D) i cant believe im having so much trouble with this. Any help would greatly be appreciated, the only thing i have not tried is loading mission planner on another windows machine, I’m not a windows fan at all and all myother pc’s in the house is Ubuntu Linux and thats the only reason i havent tried that last bit yet. thanks in advance on any tips i may try.

I’m not 100% about Pixhawk but with APM terminal was removed from arducopter 3.2 which is why you’d be getting gibberish on screen.
But, you can find motor test under “optional hardware”.

Have you tried doing an “all at once” esc calibration - … alibration

APM is a multi programmable controller and if you haven’t run it though Mission Planner and loaded the Firmware or configured it then it won’t work as it comes from the factory un-configured.


I have run it thru mission planner, everything is set up, i get gps lock, my flight modes are all
ok, compass calibrated the works, i only mention the program as i am totally lost on what
else it could be and yes the app does do stupid crap sometimes so i mentioned it.

Can you post a screenshot of the MP panel that is not populating?

As for the motor that is spinning up, have you done the ESC calibration?

Yes everything was calibrated, that one esc would never calibrate correctly, via the FC or via the Receiver method… will simply just order a replacement esc and go from there.

Here goes.

This is when i select X Quad to the right is a pulldown that always says loading

Same if i choose spider V quad (which is what i have)

Also as u can see I have mission planner V 1.3.32 build 1.1.5736

each time i open it it also wants to update but it starts getting the new files and then gives this error.

another thing i just noticed happening while taking screenshots and resizing to upload, the quad is on and all of a sudden while typing here, ESC’s that are still connected starts beeping on their own motors 3 and 4 only.

PS its a APM 2.6 board.

Looks like you’ve got a corrupted MP file. Please uninstall and download a new version. That field updates fine for me.

Did that numerous times. even tried planner 2.0

It looks like your firewall is blocking access for Mission Planner. It needs to go out to the internet to get configuration files as well as firmware to load on the quad.

Yes, if the PWM signal to the ESC’s is not there the motors will beep like that to tell you they are powered but there is no signal to the ESC’s. They all should do that.