Complete noob here <--

ok ive been at it for a week and have had no luck… and I cannot find any good tutorials or instructions…

its a tricopter… apm 2.5

ive installed firmware…
calibrated radio and accell…

im not using gps or anything other than the apm itself…

transmitter = FS-th9x
receiver = fs-r8b

when I disconnect from the mission planner and try to start it up I get the flashing red/blue then it goes yellow and blinks red…

not sure how to power the receiver, it does not power on from esc’s … ive read about the separate power supply…

not sure where I should plug the esc’s in… 123 on the receiver, then 123 on the apm?

ive noticed my transmitter uses ppm I believe… and saw some poor instruction on what to do but have no idea…

any help would be GREATLY appreciated… thanks

Without a GPS, the APM will just do nothing but wait for a GPS 3D lock which it will not get without the GPS.

Try this link:

Thank you Daedalus… so I figured it out… just had to arm it doyyy.
and thank you TCIII but it seems to work with no gps

Im getting some pretty wild spinning in circles on liftoff. Ive tried recalibrating the apm and the esc’s a few times… my battery is a little off center I dunno if that’s the cause… I flew it around the backyard as it did 360 after 360 seems ok other than that

im using the tri config on this page … nd-motors/

the only thing ive seen is to do is what ive done, any ideas on this one?

The spinning is probably caused by the fact that the heading is calculated from both the GPS and the compass inputs.

im pretty sure its got the onboard compass, but from what ive read on multiple sites you don’t need the gps unless ur using waypoints, as of right now im only looking for stabilization. this page half way down says what im saying -

and this is the only help I could find on it but remained unsolved - … e=activity

thank you

As I said before, the GPS as well as the compass provides a heading input the AHRS.


Even though your goal is just stabilization, the gps will help with that. The uBox GPS on the 3DR store is really nice. Have you made sure your trims on your transmitter are zeroed out? Then have you done the no wind hover, to dial in and save your trims?

Daedalus, I did order a gps, and ive been playing with the trims on the remote…while throttling up it starts to spin on my floor(FAST, clockwise rotation) It seems to help trimming a bit but then when I throttle more it starts up again, im guessing I have to find that sweet spot? Regardless of trim it seems to always rotate clockwise. Waiting on a charging battery now, def need to get some more(if I can ever get’r up) :slight_smile:


I’d leave the trims zeroed out on your transmitter until you can hover. If everything is hooked up correctly, it should hover fairly well with no trim input. Some other stuff to check:

  1. correct wiring order on your motors to APM
  2. no loose connections on the esc’s
  3. no reversed channels on transmitter
  4. props mounted on the correct motor (cw vs. ccw) and none upside down
  5. receiver channels connected to APM in correct order
  6. radio calibrated in mp
    Basic stuff, but seems like something basic is missing from your build.
  1. correct wiring order on your motors to APM -im pretty sure I have this right, I have the ardupilot facing forward between the 2 front motors, the motor on the right connected to output1, the left output2, the motor in the back connected to output 4

  2. no loose connections on the esc’s- not sure but im noticing when I start up the motors they all start at the same time, and when I cut the throttle 1 motor stops fast while the other spin until stop ( I would guess my problem is here unless its on my remote)

  3. no reversed channels on transmitter- I don’t think so. my left stick is(updown/leftright)" throttle/rudder" my right is “elevation/aileron” and I just noticed on the display when I raise the throttle it raises the pitch not sure it that’s suppose to or not.

  4. props mounted on the correct motor (cw vs. ccw) and none upside down- im using all pull props I think this one is ok

  5. receiver channels connected to APM in correct order- im not 100% on this, but when I hold it and tilt it right left up down it reacts like it should so im guesing yes.

  6. radio calibrated in mp-yessir

Thank you both for all of your help


Ahhh, number 4 may be your culprit. You should not be using all the same type of props, but rather matched pairs of push/pull props. Check out this link:

Im only using a TRI copter, on this page ( … and-motors ) about half way down im using the tri setup on the “left”, but I could switch out 1 of the props, according to that site it would be my #1 motor I believe. I will give that a shot and report back.

I haven’t tried the different prop yet. But the Gps came today, made no difference (I expected that)


I am curious which tricopter, motors, yaw servo, etc, that you have. When holding the tricopter in your hands, does the yaw motor react in the correct direction when you waggle the tail back and forth? When it spins on takeoff, can you counter the spin using opposite yaw control?

Hi, just built my first APM2.5 based quad. All appears to have gone well and it flies in Stabilise, Loiter and Alt hold. I have only flown once as yet and it is rock solid so far.

My only concern is that the compass motor calibration realised 197% of magnetic field, which reading the general wisdom seems very high. There does not appear to be an issue with this as yet.

My low cost options are limited to moving stuff about a bit, I don’t really want to buy an external compass unless I have to.

Is this a high reading and what is likely be the effect if it is?


I have the same quad, same controller, same problem with the compassmot reading (139%). And yeah, it is solid as a rock in Stabilize mode. But I am not going take the chance of flying waypoints, RTL, and other advanced modes that rely heavily on GPS+compass with an iffy compass. I have read too many stories of crashes and fly-aways. I would rather spend the $17 for an external compass and get it right 1st time. Besides why would 3DR go to so much trouble to release the APM 2.6 with the external compass kit unless they were correcting an obvious design flaw. I’m going mount the mount the external compass right up on top next to my GPS and hopefully fly the full capabilites of the APM with confidence.


Point taken. However, double that for postage to Europe and add 3 weeks delivery.
I am going to try a short mission in the next day or so (when it stops raining) so I should have more data. When I did the compass mot it had the 3DR telemetry running, just powered up, and the GoPro was recording plus there is some serious Wifi in the same room. I also need to run the vibration test as well (now I have read about it. I’ll let you know how it all goes.


I resolved the very high compassmot of 197% by moving the APM up about 25mm onto the next level. Recalibration delivers a compassmot of 38% with the on-board GoPro recording.

The quad now tracks on missions as it should. What am I going to do with the external compass board I have ordered?

Why not install it and try to get compassmot closer to 0%? Then you can put the APM back where you wanted it to be in the first place.

My new external compass just arrived two hours ago. It is smaller than I expected it to be.