Compiling error: easy_install empy catkin_pkg

I just tried to re-compile the software for my Pixhawk after not looking at it for a year ( my bad ).
It compiled and executed fine in my Rover.

Then I downloaded all of the software updates through SmartGit and everything looked fine.
When I tried to compile it, I now get the following message:
On Windows please run:
easy_install empy catkin_pkg

After a fair amount of digging I found that I now need PYTHON on my Windows 10 PC.
Note: I am strictly a Windows guy.
So I installed the latest version for Win 10; 3.5.0 ( 32 bit )

That did not solve my compile issue; same error.
I have never used Python.

Please help with a solution.

I had run “easy_install empy catkin_pkg” from the Windows Command prompt.
That solved nothing.

Then I noticed a small reference elsewhere that instructed to run just “easy_install empy” from the PX4
That solved everything to get the compile to run.
Other issues have since come up which will be addressed in a separate post.


Well done!
Thanks, Grant.