Compiling AC3.4.1 on Windows Error

Hey Everyone

first, congratulation for releasing AC3.4.1 !

I tried to compile it and ran into an error, that the “include/mavlink/v2.0/ardupilotmega/version.h” is missing.

I’m on Windows7, using the PX4Toolchain and Eclipse. I have freshly cloned the repository, and of course did git submodule update --init --recursive (I in fact did the whole thing now twice, to double check)

The include file under question is called in GCSMavlink.h.

In an attempt to find the issue, I scanned the folders on my disk, as well as the various githubs. What I note is that in my “github/ardupilot/modules/PX4Firmware/mavlink/inlcude/mavlink” folder I do have only a “v1.0” subfolder, while in the PX4 firmware github repository I find in that folder also “v2.0 @ 094e765”. I thus naively would guess that this is missing somehow.
I also note that shortly before AC4.3.1 was released a PX4Firmware:submodule update was pulled.

No idea what’s going on. Any help would be appreciated.


try adding lxml and future libraries

see here:

I believe these have been added to the latest toolchain

Thx for the quick response

I will try

at this point I can’t help and oomplain for the Xth time about this “clever” practice to call the toolchain “pixhawk_toolchain_installer_latest.exe” and not give the user any chance to check if she/he is updated (except to dig deep into some issues). With all due respect, how annoying is that.

now let’s see how the new toolchain does :slight_smile:

It will be a better/smarter way to install the toolchain on Windows, but at the moment there are too many “moving parts”, so it’s hard to keep the process streamlined, but we’ll get there :slight_smile:

I agree the naming is not perfect. The reason is behind naming it that way is that it means links on websites, don’t need to be updated when updates are made.

On a side note: With the success of package managers like apt & yum on linux, brew and macports on OSX. With CocoaPods and Carthage, that Windows would have created some similar by now and avoid what is essentially a nightmare. :wink: (Maybe there is one, I just haven’t heard about!)

Luis, big thx for the hint to the px toolchain, this indeed solved the compiling issue
the type of error put me totally on the wrong track

as regards the naming/versioning issue: I understand that it makes maintaining the docs somewhat easier, and that was my guess for the reason, BUT: by that logic you also should rename AC3.4.1 into AC_latest, and AC3.4 should have been AC_latest, ah, of course all the other, AP,AR,AS, also should be latest, and then we have all ground control stations, and … you seriously should do that, it would bring some funny times, I guess :smiley: … I would think that it could be easily solved with a simple php (or whatever) script …

I think, at least, it could have been mentioned in the release notes

thx again

That was the truth. The ground station downloads where named _latest. I remove it for APM Planner 2.0, cos i like you don’t like it. :wink: it gets confusing. but at least with the GCSes we have an About Box in the menu!

Does the installer have a command line switch so you can read the version?

pixhawk_toolchain_installer_latest.exe --version

If not maybe it could be added?