Compiling 3.4 with make does not work

I have tried compiling my own version with make for Pixracer and have very little luck. The compile works just fine on both Windows and Ubuntu but when I try to fly it the motors go wild and the quad is uncontrollable.

A couple of time I have gotten it to compile and work just fine but I am trying to keep up with all the changes that are being made.

Is there a way to find what is not compiling correctly. There are so many objects that comparing then is impossible. I suppose if I got a compile listing of a good build and tried to build that exact one I good check file sizes and code to see if they match.

I am using make px4-v4 and have tried comparing windows against Ubuntu by they are totally different. I would have thought that since it’s compiling for another processor that the compiles should be the same no mater where you build it but that does not seem to be the case.

It is very scary to takeoff not knowing if it’s going to fly correctly even thou you didn’t make any changes. And it’s only the motor out that has a problem. All the other features and sensors work just fine. It’s like a designed bug to stop other people for making there own version.


Obviously there’s no bug to do that. All our build system scripts are in Github…

If you need help please refrain from such insinuations and post all the steps you are making to build ArduPilot.

I thought it was obvious.

open terminal window
git clone
cd ardupilot
git submodule update --init --recursive
cd ArduCopter
make px4-v4
attached is a session log.

Make px4-v4.txt (194.5 KB)

bench test log with motors going to max.

140.BIN (660.2 KB)


I don’t see nothing wrong in the session log. What compiler (and version) are you using?

Installed the current Ubuntu software with all the latest fixes. What command would you like me to run. The issue is everything works and starts up, it’s just the motor mixers seem to go wild.
I have gotten a couple of compiles to work correctly but now it’s like Russian roulette as to when it works or not.


You have to install a cross-compiler to build PX4 so you certainly have installed something. Anyway the compiler we use for PX4 is at

Just checked that and I do have that version of the cross compiler. Did a mention that it compiles the same on windows and Ubuntu. Both versions fly off.


I’m out of ideas to help you. My last suggestion would be to try waf instead of make, but PX4 support in waf hasn’t been very tested - it should work and give no problems but, as always, try at your own risk.

I’ve had a look at the log. It looks like the vehicle is in stabilize mode with the throttle just slightly above zero (8%). Because of this the vehicle thinks it’s flying but it’s likely sitting on the ground because the throttle is not high enough to get airborne. It’s trying to control it’s heading but it’s unable to most likely because it’s physically not able to rotate (because it’s not flying). In this situation the yaw controller’s I term builds up and up and so it spins just one (or two motors) at a higher and higher level (it’s motor #1 in this case that goes high).
I don’t see an error here though so I’m going to close the issue.