Servers by jDrones

Compatibility with mission planner configuration


(James Miller) #1

Beginner here–thanks for your patience.
I configured my pixhawk plane with MP, but need to use a tablet in the field to do the compass dance, as well as flight monitoring. I don’t dance so well- wheelchair-bound… must I reconfigure everyrthing using qgroundcontrol?
How do I get my android tablet (no full-size USB port) to operate the SIK radios? Is all I need a USB to micro USB adapter?


(James Pattison) #2

No need to compass dance any more!
Read through this thread Testers needed for in-flight compass learning
A USB OTG cable should do the trick for your sik radio.


(DonLakeFlyer) #3

There is no need to redo anything if you setup using MP and then fly with QGC (or the reverse). All setup parameters are stored on the vehicle. So you can go back and forth between whatever ground station you like.


(armadillo) #4

I have not had a problem but I have heard that you might need to be careful choosing the correct tablet, OS, OTG cable combo. If things don’t immediately work out of the box, suspect the OTG cable. Also, note that, getting a solid green on the radios is no indication of things working end to end. The solid green shows that the radios see each other. If there is a problem with the radio data getting through the cable, the OS and into whatever app you use for GCS, the radio doesn’t have a clue about it.


(Shawn) #5

Once calibrated, there’s actually no need to do the compass dance at all unless you change something on the craft. You can even move great distances between flight locations and declination comes from an inbuilt table in ardupilot.
Just make sure the parameter to look up the declination automatically is set to enabled: COMPASS_AUTODEC


(James Miller) #6

Thanks, everyone. good help. Got it working fine, —then I went and added a second gps. which remains invisible to my pixhawk 1. Bah!