Compass will not Calibrate

I was working on a couple of copters this morning and had to do a compass calibration on each.
A small quad has 3.2.1 and calibrated fine.
The large hex had issues with 3.2.1 so I downgraded it to 3.1.5 which had worked wonderfully in the past.

The dialogue comes up and I do the dance for 60 sec, the offsets are displayed but the data is never saved to the hex.
The GCS continually gives the arm fail warning ‘compass not calibrated’.
checking the messages pain it indicates that “FAILURE: Unsupported CMD: 242”

So now I cannot calibrate the hex???

Anyone know what might be going on?
Anyone got any ideas on a fix?

APM Planner v2.0.17 (47bd731d-2.0.17)
Mac OS X 10.10.2
Debug console text attached

1 Like

I assume you are using an APM2.5/6 HW? I will test to see why it’s not working.

Yes, I am using APM 2.6 with 3DR external compass

I also found the Accelerometer calibration window does not recognise the keyboard so the “press any key” action does not work.
To go from one position to the next I had to press the button on screen each time.

I’m anxiously awaiting a solution for this too. I have the same error message along with a list of unknown parameters that are preventing me from arming my quad.

You will need to provide some detail on your setup please.

Firmware version?
Hardware version?
PC type and operating system?
OS version?
GCS version?
Operations performed?

Post a log. My first guess would be that its not related to APM Planner 2.0

I’m using:
APM Planner v2.0.24
CX-20 Open source firmware ardu copter V3.1.2
OSX 10.12.3 Sierra

I’m trying to get stable flight so that I can use some of the telemetry enabled functions out of Tower app

I was able to get the motors to arm and CMD error 242 to disappear.
I performed a manual compass calibration by Holding the throttle (right stick) down/right within 5 seconds of plugging in a battery. The yellow and red light flash told me that I was in calibration mode. I did a few 360s and completed the calibration.
I armed the blades on my mode 1 controller by holding left stick down/right and throttle (right stick) down/left simultaneously.
now when I attempt to take off the copter flips on it’s side. I now need to find out how to calibrate the thing to fly upright. Any suggestions?
THanks so much for the speedy replies!
Kind Regards!

Log read out:

[MAV 001:1] barometer calibration complete
[MAV 001:1] ArduCopter V3.1.2
[MAV 001:1] Initialising APM…
[MAV 001:1] barometer calibration complete
[MAV 001:1] Calibrating barometer
[MAV 001:1] barometer calibration complete
[MAV 001:1] Unknown parameter ATC_RAT_PIT_P
[MAV 001:1] Unknown parameter ATC_RAT_PIT_I
[MAV 001:1] Unknown parameter ATC_RAT_PIT_D
[MAV 001:1] Unknown parameter ATC_RAT_RLL_P
[MAV 001:1] Unknown parameter ATC_RAT_RLL_I
[MAV 001:1] Unknown parameter ATC_RAT_RLL_D
[MAV 001:1] Unknown parameter ACCEL_Z_P
[MAV 001:1] Unknown parameter ACCEL_Z_I
[MAV 001:1] Unknown parameter MOT_THST_HOVER

I’m not sure what effect the “unknown parameters” have.

I think you have some reading to do here

Have you connected to a computer via USB or Radio?

Your calibration commands don’t sound correct.
Arducopter is armed with throttle down and right rudder for 4 seconds.

Have done the accelerometer calibration?
Compass calibration?

Read the section in the Wiki regarding downloading the flight logs from the controller.