Compass trouble.... "Setting new offsets for compass #1 failed"

Hello. I have been trying all day to calibrate my “external” compass/gps. I have an APM 2.6 and I’m running “Mission Planner 1.3.44”. I have been going through the “Manditory Hardware” setup and I keep getting the error " Setting New Offsets For Compass #1 Failed". I have the compass orientation set to “NONE” as I have it installed horizontally above the APM. I have updated the firmware as well. Can anybody help me out? Thanks :slight_smile:

welcome to the club - mee too … :frowning:

Most GPS/compass modules require Roll180 orientation because the mag IC is facing down on the module PCB.

Ok. I tried it again with “roll180” with same results. Is there a jumper that needs to be cut inside the APM if connecting an external compass? I read that somewhere.

Only on FC’s with internal compass’s. 2.6’s do not. 2.7’s and 2.8’s do and there is a jumper to be removed to disable the internal compass.

please try the latest MP beta.
this should be resolved

I’ll give it a try. I’ll post the outcome. Thanks.

I can’t seem to find the beta mp. Anyone have a link to it?

help > update beta…

Ok. Thanks :slight_smile:

yep - update to beta did it.

Yeah…worked for me as well. It didn’t seem to capture many counts before it ended…but i check mission planner and the north, south, east and west look correct when i point the quad in each direction.

Thanks everybody for the help. I’ll give an update on the flight.

I tried to update my version of M.P. with the beta copy and the update failed. I’m using 1.3.44 M.P. on a Windows 10 machine. Do I need to uninstall M.P?