Compass Orientation... I am confused

This page says: " If the Magnetometer board is mounted in its forward facing direction (Drone logo on the tab facing forward and in the opposite direction of the Y arrow) the (COMPASS_ORIENT ) parameter will need to be set to (Normal) or “0”."
–> Y should be facing rear, and X should face left.

This page says that X is forward and Y is right.

But I also wonder what I need to set… The value that I enter in this dialogue box - does it indicate how I rotated the compass while mounting, or does it indicate how the compass should be rotated back from its mounted position…?

And do I need to reboot / recalibrate the compass to see any effect in the HUD…?

And finally, any idea on what to enter in the above box for my orientation?

Thanks for your input!!


Why Yaw45? by process of elimination, you can at least limit your possibly correct selections to multiples of 90°…

I THINK you’d need Roll180Yaw180, assuming I have my 3-finger xyz rule correct from college physics…

see here:

  • Northern Hemisphere: - Z-component should be positive - when pitching the vehicle down, the X component should increase in value - when rolling the vehicle right, the Y component should increase in value
  • Southern Hemisphere: - Z-component should be negative - when pitching the vehicle down, the X component should decrease in value - when rolling the vehicle right, the Y component should decrease in value

Worst case, just try the multiples of 90° until you get the correct response per the above link.

Hi, this was just a random selection from the list before taking a screenshot. I’ll try what you suggest!

Where are you located? Northern Hemisphere? or southern?

Northern Hemispheere

What is your current setting?

Is your Z-component positive?

With orientation set to none, and copter physically pointing south: Z is +400, y is -15and x is 234

OK, great. Set it to Yaw90 to start. Then pitch the copter down/forward. Does the X-component increase? or decrease?

But I just notice that nothing changes when I move the copter…

Oh, well you obviously need to sort that out first. Can you show us a diagram of your wiring? Which flight controller are you using?

I am using the Kakute F7 (non-aio):

The compas is wired to SDA/SCL (I need to double check the “polarity”), and it has worked before with INAV firmware.

Sometimes it shows zero for mx, my and mz, and sometimes the values I mentioned above.

How can I find out if a compass is detected at all? And which number will it be? #1, #2 or #3…?

Seems that it is properly connected…

… now I reset all parameters to default, and the compass is finally working. Now I need to find out the orientation as you suggested…

Autorotation didn’t determine this and set it? It has worked for me. It was on a Plane but I think it’'s the same function in Copter.

Thanks for all your comments.

Because this happened all the time, I decided to change to inav firmware. In inav everything instantly worked (including the compass), so I am using this firmware. It’s a bit sad for me, because I would have preferred ardupilot, but the compass behavior was strange.