Compass offset changed

Hi, its been a while since I calibrated compass for last time. I rebulid quad to new frame from F450 to S500, upgrade fw to latest rc6 and recalibrate compass.
My previous values was around 40 40 -40. Now I have 44 237 17. Should I be bothered or is it still ok?
I have Ublox M8N GPS with compass.

I went for a test flight but endup crashing in 2 second. During takeof quad start leaning on one side, so I tried to compensate, but in about 1m up in air, quad start roatating and crash.
I tried to analyse the log, but I am not good at reading it.
(btw for some reason it shows date 1.1.2000 why?)

I checked the compass EKF in MP and it shows value under 0.5, sometimes 0.6 (orange color)

Can anyone help please?

Also tried compasmot calibration with this result:

I guess interference over 70% its a bit high isnt it?

I found out that i reversed polarisation for GPS module (gnt o 5v and 5v to ground) Is it possible that it is burned? I have no GPS in MP (but compass shows orientation well - UPDATE it was probalby internal compass, external doesnt react)

I disconected gps moduel completely and test internal pixhawk compass. Set compas 2, start calibration and see this:

As you can see circle is way off the main Y axis. It was exactly the same with M8N module. Also got simmilar Y offset: 113 223 -10.
On Flight Data screen it shows Bad compass Health. An compass headed 180 degrees in wrong direction (North instead of South)

I have had initial compass calibration screens like this.
First I unchecked ‘Auto Accept’.
Then I rotated around all axis’s until I had good density of measured points, about 3000.
The more points I recorded the tighter and better spherical the calibration map looked.

Its not about point density, but circle is off the main axis… Anyway I think I got it…
I connected GPS polarity reversed, so most likely gps module is fried. It seems like compas was working but it was internal compass from pixhawk. And this one had some offset in one axis. Even thoguh it doesn explain compass bad health…

Sorry for the slow reply.

So I think the “bad compass health” will have been reported because it thought you have two compasses but one (the external one) doesn’t seem to be working. I can see this in the logs because COMPASS_DEV_ID and COMPASS_DEV_ID2 are both 131594. This number is for the internal compass. If the external compass were working COMPASS_DEV_ID would be 73225 (on a Pixhawk). That all means that the external compass was working at some point in the past when you did a compass calibration but wasn’t working in this log file.

Now, the really bad thing is you shouldn’t have been able to arm with an unhealthy compass. I’ve reproduced the problem though so I plane to make a fix and release with AC3.4.2. You can track the progress of this issue here.

Re the big offsets on the internal compass which leads to it appearing way off center in the MP’s live calibration screen - that’s pretty normal.

Thanks again for the report!

I bought a new GPS module, reinstall but problem with compass presists…
Quad orientation shows correctly (south, north) but no gps fix
EKF was at full red, after a few minutes it dropped to zero by itself.
COMPASS_DEV_ID1 and ID2 are both 131594
Compasmot calibration shows 80% interference.

So I upgraded FW to 3.4.2. rc2.
After boot I have GPS fix almost instantly.
COMPASS_DEV_ID1 and ID2 are still both 131594

My bad… I have switched compass wire… after reconnecting it looks ok now