Servers by jDrones

Compass, Loiter, Motor Balance issues

(Oliver Zöller) #1

Hi all,

I’m going mad here.

Pixhawk2, Tarot 650, nothing crazy.

Compasses are calibrated (repeatedly), ESCs are calibrated (One-by-One now, doesn’t solve anything), got two GPS’ now.


  1. Motor Balance fails sometimes. CoM is perfectly fine (tested it), ESCs are calibrated, motors are the same and same age.

  2. Whenever I switch to Loiter, the quad accelerates in one direction until I switch back.

I’ve run out of ideas on how to fix it. Compass calibration is not “relaxed”, but on default. Only using the two external compasses (M8N) now to avoid interference of the internal ones with ESCs. Checked for twisted motors etc., all looks fine.

I’ll attach some logs, maybe one of you finds something helpful. Thank you, guys!

(Max Kräh) #2

I have the same problem. I found out that my compass heading is wrong (90 degrees)
have a look here:
I tried to disable the QMC5883L driver with COMPASS_TYPEMASK but I don´t find the parameter in MP.

(Oliver Zöller) #3

Thanks for your input.

Tried all that, re-calibrated a bunch of times, put in all kinds of orientation angles, nothing helped.

Ordered the same GPS/compass unit and did the same thing, no more problem. Weird stuff. But at least it’s working now.

What’s really weird is that now for the first time, I get a compass FAIL in the AutoAnalyzer.

I believe that’s caused by the internal (unreliable b/c of ESCs too close to Pixhawk) and external compass being inconsistent though.