Compass Live Calibration: Calibrates off axis away from white points

I have APM:Plane setup on a Skywalker 1900 using a Pixhawk. During the first setup and the next couple of times, compass calibration worked as expected, using the Live Calibration method.
Last week, I wanted to recalibrate my compass but was unable to do so.
When I perform the calibration, the data points are getting registered, but none of them hit the white points. Also the sphere of data points that are recorded, is offset from the origin and the entire sphere is displayed in a different quadrant(or octant?). I have tried multiple times, but failed. I even reinstalled MP and then upgraded to version 1.3.44 but the same issue was persisting. I will be trying with 1.3.45.
Is this a bug in MP or am I doing something wrong?

Thank you.

I had exactly the same issue trying to calibrate on a traditional Heli. The sphere of collected data during the calibration was off axis initially, then seemed to center itself and collect the data points but the calibration would fail and I would have massive offsets. I tried everything and eventually brought a new controller and compass… This worked but even the first couple failed and when it did pass it was close. I took off auto accept from the calibration window and really made sure I gave it good coverage as much as I could, I also checked that there were no errors before I clicked the done button and shifted a telemetry extension that was passing near the compass. As a matter of interest, I was also setting up a sky walker at the same time and didn’t seem to have too many issues with that. I read also in another thread that others have had success in ironing out wrinkles in their calibrations by passing a magnet over the compasses and then recalibrating, this did bring my offsets down somewhat on my old pixhawk but not enough to pass calibration.