Compass = GOOD - No MAG data, unable to test mag_field inte

Since day one (about year) when I carry out Auto Analysis of a dataflash file I get the following
Compass = GOOD - No MAG data, unable to test mag_field interference

System flies good in all flight modes I have seen other folks seeking the same lines but no explanation as to why we get this… is it because I have COMPASS_LEARN disabled? Is it a concern or simply because of a parameter set to null.

its because you don’t have mag enabled in the logs, so the auto analysis can’t check it.

Are you referring to the drop down list under the LOG_BITMASK parameter as to what is being stored in dataflash log?  I don't see anything there for mag.  Or do I have to edit a line in the LogAnalyzer script?

Thanks for taking the time to my question,


Screen capture of LOG parameters, which one should I enable for mag data; currently have default or to check vibes I sometimes enable default + IMU

I could go trial each selection but if someone readily knows that would be great

Further reading led me to this… " Note that the COMPASS message is not enabled by default in the dataflash logs because it runs at 50hz and does affect CPU performance a bit ‘’ Was it an option at one time under Log Bitmask?

As of yet I am unable to find topic of how to enable dataflash recording of compass data… is it because we can not and have to rely sole on Tlog’s RAW_IMU xmag, ymag and zmag fields ( read info where some guys were doing the task with math and excel )