Compass calibration problem

Good day im seting up my ardupilot apm 2.8 for the first time however i can get the compass callibration to work , i have tried the internal and external compass and i have tried apm planner 2 and the latest mission planner. Please help me?

You need to be more specific. Give us a detailed step-by-step description of what you are doing and what errors or other indications you are getting…

Ok so i have installed V3.2.1 and even V3.1.0 i then callibrated the accelerometer and the radio however when i try to callibrate the internall compass or the external compass even when i remove the jumper for the external compass it does net regester any reference points it just sys error 99 on the top leftimage

Where did you connect the compass on the Flight Controller? A common mistake on these old 2.8’s is to connect to the I2C port. You want the port below the GPS connector. Go back to 3.2.1 and leave it.

Hi Dave sorry i forgot to mention i dit connect it just below the gps . Do you think the flight controller might be dammaged?

Take a screen shot of the compass setup page. Use Snipe I can’t see anything in the photo you posted above. Did you select the “APM and External Compass” button? Post your parameter file also it might be useful.

Hi dave sorry to ask but what is snipe?

Screen capture. Taking a photo of the screen produces a poor quality image.

Ohhh sorry the forum wont allow higher qualty pictures maybe i can email them to you

Sure it does. Here is a screen capture of the page I’m asking you to post. It’s from an APM, yours should look similar. Post the parameter file also.


Thanks my page looks exactly the same i will but i will upload my param in a few ours as its 23:30 in South Africa. Thanks for alll you help